MacBook 12 on Mojave Triple Display with DisplayLink 5.0?

What is the current status on using the UD-ULTCDL with a MacBook 12" 2015 running Mojave (MacOS 10.14) and using a DisplayLink 5.0 driver? Can I use a triple display configuration, ie. 2 external displays and one internal? Or can I only upgrade to High Sierra 10.13.3 with the 4.3 driver?

I’d like to make use of the Parallels 14 implementation / Fusion virtual machine running Windows 7.0 with OpenGL 3.2/3 for AutoCAD.

DisplayLink claims on their website that the new 5.0 driver works with Mojave in multi-external display mode, but no word from plugable where the info is outdated on this website.

Hi and thanks for posting!

In our testing of DisplayLink 5.0 with Mojave (dev/public betas, and starting today, the public release), things have worked well for most of our MacBooks including a 12" 2016. (The only Mojave-compatible system we’re aware of that is not working properly with Mojave and DisplayLink is the Mid 2018 MacBook Pro. As you may have read, DisplayLink expects this to be resolved in a future OS update.)

Because of how frustrating the regressions in macOS 10.13.4 were for DisplayLink users (including those of us who used this combination here at Plugable!), we are not changing our list of officially supported platforms at this time, but we hope that can change as things progress. We’ll certainly continue to share what we learn as we continue to test and receive user feedback.

So while we’re not yet officially recommending/supporting macOS past 10.13.3, we would expect all displays outputs from the dock to function on your system if you choose to update to Mojave and DL 5.0. Regarding your specific use case, with the complexity of virtualized environments in general and specifically with Mojave now dropping support for OpenGL, it’s unclear whether things will work as intended with Parallels. Because rolling back to a previous OS can be a pain, it would be worth checking the Parallels site in the days ahead to see if anything relevant is posted that may help guide your decision.

If you do decide to give it a try, we’d of course be very interested to hear how things go!

Best wishes,

Parallels has been very slow to move from OpenGL 2.1 to OpenGL 3.2, which it only supports in the last release 14. VMWare Fusion has been doing that since longer. That said, the OpenGL things is generally a nightmare they way how Parallels treated it. Yet, the OpenGL use is in my case only important to run AutoCAD within the Windows 7 Pro virtual machine, so technically the Parallels implementation should do the translation between Metal on macOS side and OpenGL on Windows side. But the point is well taken.

Stupid question: When I upgrade my current Yosemite to High Sierra with a target to stop at 10.13.3. How do I stop the Mac from going beyond 10.13.3?? Are the 10.3.1 through 6 updates sequential updates or does an upgrade from 10.10 to High Sierra automatically load the 10.13.6 version with no way to stop at 10.13.3?
Background: I did not bother to upgrade to High Sierra as my system runs fine and Parallels was stuck at OpenGL 2.1 so there was no reason to. Only now there is the Mojave incentive, but…

And further: How about Duet? Is that supported under Mojave with the 5.0 driver? Or is that dead?

Ah, appreciate the additional context. Hope the Metal to OpenGL translation works and performs well.

To make the decision even more difficult, unfortunately getting to 10.13.3 from 10.12.x is going to take some extra steps/time, since Apple no longer publicly hosts the 10.13.1 image directly. (Though last I saw Apple still does host a 10.13.1 to 10.13.3 supplemental update.)

I can’t link to the posts directly (or speak to the integrity of the bits!), but there have been several users on the DisplayLink Mac forums who have posted guides to the process.

Haven’t seen any updates regarding Duet and Mojave recently, so unsure how well/if that’s working with 10.14 at this point.



Did my Mac OS Mojave upgrade yesterday, the external monitor works well, however the external Mac keyboard no longer works. Any suggestions a/o solutions for this?


Sorry to hear. We’ve not encountered that specific issue before.

Have you already tried resetting the dock after the upgrade? If you haven’t already done so, fully unplug the dock from all devices, power, and USB-C cable to the host computer. Wait about 30-60 seconds, then reconnect the power cable first, USB-C host cable next, and USB devices last. Sometimes a reset in this order can resolve this issue.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.