Mac OSX "Digital Viewer.app needs to be updated"

After upgrading my Mac OSX I’m no longer able to run the Digital Viewer app due to an operating system incompatibility with the latest version of the app. Are you guys aware of this issue? Do you have any plans to fix it?

Digital Viewer app version: Digital_Viewer_3.1.08
Mac OSX version: 10.15

28%20AM

Hello,

Thanks for your post! We apologize for the difficulty getting the Digital Viewer program to run. In our testing, the current version of macOS, Mojave 10.14.5, has no problem running the program, but will prompt about the need for an update for 64-bit compatibility. We are investigating a potential upgrade to the application with 64-bit functionality in time for the public release of 10.15 Catalina.

Could you please confirm if you have elected to try the macOS 10.15 Catalina beta? If you are using the beta, we would recommend using the Photo Booth application at this time. Again, we do a apologize for the trouble, and look forward to hearing back from you soon!

Thank you,

Kevin
Product Owner
support@plugable.com

Oh Photo Booth is a great suggestion. I’ll give that a shot! Thanks! And, yes, I am using 10.15 Catalina Beta.

Good to hear back from you! Sounds like a plan, please let me know what happens, and I’ll be here to help. Thanks for confirming the Catalina Beta.

Thank you,

Kevin
Product Owner
support@plugable.com

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.