Mac 10.6.8 and md_PL2303_MacOSX10.6up_v1.5.0


#1

HELP!

The driver installs ok and I get the Serial Controller D in the Profile but no /dev/tty.usbserial.

I followed the uninstall procedure for 1.4.0 (could not find for 1.5.0) and tried to install 1.4.0. Says I have a newer version already installed. ugh

I have a cisco that I have to configure TOMORROW.

Thanks,
wbl


#2

Hi William-

Thanks for posting with your issue, I’ll be happy to help!

The 1.5 driver is the latest greatest version, newer than the older 1.4 version. Is there some reason you’re trying to use the older version?

Also, just for public record, our install walkthrough for USB Serial on OS X is at the link below if you’d like to work ahead: http://plugable.com/2011/07/12/instal…

Let’s first verify which kernel extension/driver you’ve got loaded so we can make sure the driver install actually worked by doing:

kextstat | grep prolific

My system returns:

127 0 0xffffff7f81fd4000 0x8000 0x8000 com.prolific.driver.PL2303 (2.0.0)

Note that version 2.0.0 is reported even though I’ve installed 1.5. Please let me know what you find for the command above and the additional detail will help recommend our next steps.

If we find the above driver is loaded, we’ll move on to checking USB serial device enumeration using:

ioreg -c IOSerialBSDClient | grep usb

Best wishes-

Jeff Everett
Plugable Technologies


#3

Oh thanks.

1.5 is the newest. I tried to install 1.4 because 1.5 did not work. I think* I may have tried to install with USB connected.

I currently get nothing with
“kextstat | grep prolific”

-wbl


#4

Hi William-

Sorry, I should have mentioned that the adapter must be connected when you run kextstat, nothing is normal response if the adapter isn’t plugged in.

Please try with the adapter plugged in (if it wasn’t already, or let me know if it was) and we’ll go from there.

Best-

Jeff


#5

Ok.
We still got nada.

-wbl


#6

Hello?
I had to make dinner for kids.

-wbl


#7

Hi William-

It was meal time for me too :slight_smile:

Lets go back to making certain that the device is detected.

Are you seeing anything in system profiler for the device as shown below?

!](https://d37wxxhohlp07s.cloudfront.net/s3_images/885296/876f7cbb-c750-4ac3-9bea-ff3447889084_inline.png?1365647277)](https://d37wxxhohlp07s.cloudfront.net/s3_images/885296/876f7cbb-c750-4ac3-9bea-ff3447889084.png?1365647277)

Best-

Jeff


#8

I fixed it and I feel bad b/c of your prompt help.

I uninstalled it. (I don’t think it ever really installed) and installed the sourceforge version. I just got it to work.

-wbl


#9

Hi William-

Thanks for letting us know you’re up and running!

FYI 1.5 was just released 4.8.13, and is recommended as it solved an issue where OS X could crash if all connections using the cable weren’t properly terminated before it was unplugged. I’m not sure of what (if any) issues the sourceforge version you’ve used might have.

Here’s a link to the 1.5 version we recommend:
https://s3.amazonaws.com/plugable/bin…

Don’t hesitate to let us know if you run into questions in the future.

Best wishes-

Jeff


#10

Dear Jeff,

i am trying to install the 1.5 version but at the end of the process the installer says: FAILED without any reasons.

My MAC is:

System: OS X 10.8.3 (12D78)
Identificatore modello: MacBookPro8,1
Nome processore: Intel Core i5
Velocità processore: 2,4 GHz
Numero di processori: 1
Numero totale di Core: 2
Cache L2 (per Core): 256 KB
Cache L3: 3 MB
Memoria: 8 GB
Versione Boot ROM: MBP81.0047.B27
Versione SMC (sistema): 1.68f99


#11

Dear Jeff,

here is the report of INSTALLATION:
Jul 5 13:55:16 MacBook-Pro-di-GEO.local installd[588]: PackageKit: ----- Begin install -----
Jul 5 13:55:39 MacBook-Pro-di-GEO.local installd[588]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=121 “An error occurred while updating system extension information.” UserInfo=0x7fe402d00600 {NSUnderlyingError=0x7fe402d16470 “The operation couldn’t be completed. (kextcache error 71.)”, NSLocalizedDescription=An error occurred while updating system extension information., arguments=(
“-update-volume”,
“/”,
“-Installer”
)} {
NSLocalizedDescription = “An error occurred while updating system extension information.”;
NSUnderlyingError = “Error Domain=kextcache Code=71 ““The operation couldn\U2019t be completed. (kextcache error 71.)”””;
arguments = (
“-update-volume”,
“/”,
“-Installer”
);
}
Jul 5 13:55:40 MacBook-Pro-di-GEO.local Installer[579]: Install failed: Installer ha incontrato un errore che ha impedito l’installazione. Contatta il produttore del software per ottenere assistenza.
Jul 5 13:55:40 MacBook-Pro-di-GEO.local Installer[579]: Displaying ‘Install Failed’ UI.
Jul 5 13:55:40 MacBook-Pro-di-GEO.local Installer[579]: ‘Install Failed’ UI displayed message:‘Installer ha incontrato un errore che ha impedito l’installazione. Contatta il produttore del software per ottenere assistenza.’.


#12

Hi geo-

Thanks for posting with your issue!

I don’t think we’ve seen this particular issue before, and in googling around it seems that the kextcache error 71 is most often due to an existing corrupted kernel extension. Permissions issues also seem like a very real possibility.

As a first step, could you please run the “Verify Disk Permissions” utility in the OS X “Disk Utility,” then try the installation again? If the installation doesn’t work, can you please reply with the output of any folders/files it repairs permissions issues with (I know this may be a lot).

Whether or not the disk permissions tool finds a lot of stuff to work on should help indicate what extension might be having issue if the repair doesn’t solve the problem.

Best wishes-

Jeff Everett
Plugable Technologies


#13