M2 SSDs not recoginsed (multiple)

I have tried multiple (2) ssds in the plugable enclosure and on different computers and used different cables where other usb c ssd drives work fine off the same drive but I cannot get multiple systems to recognise any drive on windows 10 when I try to see the drive in the computer management area. It just shows up as a realtek device and there are no formatting options


Thanks for reaching out to us, I am sorry this is not working as expected and I am happy to help!

Thank you for letting me know you have tried multiple SSDs, systems, and cables. When you have a moment, please let me know the manufacture names and model numbers of the SSDs tested with this enclosure.

The Plugable USB-C to NVMe SSD enclosure is only compatible with M.2 NVMe SSDs, while M.2 SATA SSDs physically fit into this enclosure they are not supported by the USB 3.2 to NVMe bridge chipset. I would like to start by verifying that both of the tested SSDs are NVMe SSDs and are expected to work with the enclosure and we can go from there.

If they are both SATA SSDs and are incompatible with the enclosure I can also help to start the return process for the enclosure.

Thank you, I a look forward to your replay!

Plugable Technology


We’re closing this thread due to inactivity, but if you have any further questions please feel free to contact support@plugable.com and we’ll be happy to help.


Plugable Technologies