Limited working and then giving up the ghost


#1

I have a Lenovo z51-70 running Ubuntu 15.04 and have bought the USB dongle as there are known driver issues in Ubuntu with the on board device. I have permanently disabled the onboard wi-fi wlan0 in /etc/network/interfaces (inserting iface wlan0 inet manual). I have the laptop 2 m away from the router and have a strong signal. When the computer is first started and Firefox launched I can load maybe two or three pages in succession, but after this Firefox a Server not Found message and the connection is lost. Reconnection is impossible until the laptop is restarted.

Any clues?

Drew


#2

Hi Drew,

Thank you for posting about the Wifi adapter. I’m sorry it isn’t working well for you.

Could you tell me what kind of network you are operating on? Is it a home, office, or institutional network (like a hospital or university)?

Also, if you have a chance, could you try the adapter on another computer to see if you have the same issue?

When the adapter fails, please check ifconfig and see if it still shows and if it still has a valid IP address.

Thanks,

David
Plugable Support


#3

Hi David,

Thanks for your quick response.

I’m operating on a DHCP home network Class A. Router is a SKY hub address 192.168.01.

I’ve also got a Lenovo Thinkpad E530C running Ubuntu 14.04 LTS which I’m using now. I have tried this with the dongle too. The process I followed was…

Inserted dongle. Opened terminal and ifconfig revealed wlan0 Centronics and wlan1Realtek dongle. I disconnected wlan0 using the icon at the head of the display and in the terminal using sudo ifconfig wlan0 down. I then opened several webpages sequentially in Firefox, which it did, but after about the sixth page it then failed to open a page selected from my bookmarks and after some time trying reported Server Not Found. ifconfig reveals that no IP address is active and a ping of the router returned a sendmsg: No buffer space available.

The above process has the same result on my new Lenovo Z51-70 with a different onboard wi-fi card.

Incidentally, I tried the process a second time on my E530C because I couldn’t recall the ping message exactly and I was able to sequentially load c.20 pages before everything failed and I was able to verify the ping message.

I hope this helps.

Drew McCormick

PS I have recorded my desktop for one of these exercises and can provide this so that you can see my actions and terminal.


#4

Oops, sorry. Just noticed an error above. I used to run a class A network (10.0.1.x) at my home office but no longer after I retired. It is now a Class C hence the 192.168.0.x (of course).


#5

Further news/information…

After pursuing the “sendmsg: No buffer space available” issue, I appear to have solved it on my 14.04 LTS Lenovo Thinkpad E530c by increasing the value of /proc/sys/net/core/wmem_max to 83886080 as advised in an Ubuntu thread. However, doing this on my new Lenovo Z51-70 with 15.04 OS increases the number of pages that can be addressed sequentially to >20, but it has the same result in that the system eventually disconnects, ifconfig reports no connection and pinging results in the same buffer message.

Drew


#6

Hi Drew,

I’m sorry for the delay in answering. For some reason our system has stopped giving notifications of replies.

I would like to test and send you a replacement adapter. Could you please contact us at support@plugable.com and send your Amazon order ID and your preferred shipping address?

Thanks!
David


#7