Lenovo X1 Carbon

I’ve been using my Lenovo X1 Carbon with three monitors for some time on a USB-C docking station. This morning I unplugged the PC, and then plugged it in again and none of the devices connected. Nothing worked. I tried changing cables, updating the firmware on the Lenovo and still nothing worked.
I had a brand new USB-C 4K dock that I hooked up. All of my monitors run 2K. When I hooked everything up with the proper connectors only two of the monitors worked. The HDMI didn’t. When I changed configurations it was always the HDMI connector that didn’t work. I plugged the HDMI directly into the Lenovo and that worked. The device is brand new. Any thoughts on what might be wrong?

Hello,

Thank you for contacting Plugable support! I’d be more than happy to assist you.

Sorry to hear about the troubles with your USB-C dock(s). Just to make sure I’m following correctly, it sounds like you had one non-4K dock that seems to have completely failed, and also a replacement 4K dock where the HDMI output isn’t functioning correctly?

Based on your description it sounds like the replacement dock is possibly our UD-ULTC4K model? Was the original dock one of ours as well - our UD-ULTCDL perhaps?

For the HDMI not working, assuming you have either of the above dock models, please make sure you’re using the USB-C to USB-C cable that the dock shipped with as not all USB-C cables can properly support the dock HDMI functionality.

Once I know more about your setup I’ll be able to assist further.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/

Thanks Josh. My old Dock was was a USB-C Triple Display Dock. I replaced it with a USB-C 4K-Triple. I can’t say for sure about the USB-C cable. I now have the USB-C 4K with the cable that shipped hooked to a brand new Lenovo laptop. I’m driving two 2K monitors plugged into the displayport connectors. I plugged my third monitor into the HDMI. As a test when I plug the same cable directly into the PC it works perfectly , however when I plug it through the doc it doesn’t work. Second question, when I test my network speed I get about 100mbs with a ethernet cable. When I just use a usb-c to ethernet connector I get about 350 Mbs. Thanks in advance for your help. -Seth

Thanks for the information!

I think we’ll want to grab some diagnostics data from your system based on these issues you’re encountering with the new dock and new Lenovo system. (Is this a different Lenovo than the Lenovo X1 Carbon you mentioned using with the old dock?)

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Once I get a chance to look at the diagnostics you’ve sent over, I can hopefully make some recommendations on how to resolve these HDMI and networking speed issues.

Thank you!
Josh

I’ve run it. Where do you want me to send the data, or do you automatically get a copy?

Thanks for doing that! Just email us the .zip file it generated on your desktop to support@plugable.com.

If you’re sending it from the same email address that you’ve used on this support forum, I’ll automatically get it. But to be sure, here’s a ticket # you can put in the email subject: 297379

Thank you!
Josh

File received, I’ll take a look and report back with what I can find!

Thanks,
Josh

Hi Seth,

Looking at these diagnostics, from what I can see, Windows thinks all three external displays are active and that the internal display is currently disabled.

I’m seeing the following three displays:

  • VE278
  • G276HL
  • VS248

From your description, it sounds like the VS248 is the display that’s connected to the HDMI port which is currently not functioning?

From a software perspective, nothing appears to be wrong, but if you’re not getting an image on that port, but the same display and HDMI cable work when directly connected, this could mean there is a problem with the port on the dock.

Can you confirm that at the time the diagnostics were run, the monitor in question was connected through the dock? Or was it connected directly to the laptop at the time?

Thank you!
Josh

Correct. I think I wrote that in my original note. The VS248 is connected to the built in HDMI connection. I did that to demonstrate that there was no issue with the hardware. When I connect the same cable to the pluggable dock it’s recognized as connected, however, no signal appears. This is a brand new Hub. FYI it’s 2K monitor, not a 4K monitor. LEt me know the next step.

Anything further on this?

Good morning Seth,

Sorry for the delayed reply over the weekend.

You did write in your original note that a display was connected via the built in HDMI, but I needed to verify if you’d plugged it back into the dock at the time you’d run the diagnostics as from a software perspective it would appear the same direct and through the dock 4K HDMI port.

Since we know this is a brand new dock, I am wondering if the old dock had any troubles with its 4K HDMI port before/when it failed.

I ask because you do have one of the affected Lenovo systems (ThinkPad X1 Carbon 7th Gen) that’s known to have troubles with its USB-C port:
https://www.notebookcheck.net/Recent-Lenovo-ThinkPad-laptops-have-a-problem-with-defective-Thunderbolt-Controllers.451061.0.html

I’d recommend as our next step, to update your system BIOS and Thunderbolt 3 firmware and see if it helps:
https://pcsupport.lenovo.com/ca/en/solutions/ht508988

Thanks!
Josh

I think I wrote all of this above:
I have a Lenovo X1 Carbon attached to a USB-C docking station. I unplugged it one day, rebooted it and the dock completely stopped working. I happened to have a new laptop and the 4K dock so I switched to that one and figured I would debug whether it was the dock or the laptop that failed. I plugged the laptop into the dock and it all worked fine save for the 4K HDMI output. As I said I know the monitor and cable are good because I use it with the Lenovo HDMI Port. I’m looking to see what I can do next. I’ve run all the updates for both Windows and Lenovo and I believe I am up to date. Let me know what else I can do. - Seth

Thanks for confirming. At this point, it’s possible that either there’s an issue with the dock (unlikely given it is brand new), or there’s a compatibility issue between our dock and this laptop model. We’ve been facing many issues with Lenovo systems, so it’s hard to discern sometimes where the cause may be originating from. Hence me wanting to double check all the facts! Unfortunately we do not yet have this model laptop to test ourselves to confirm compatibility on our own.

At this point we either need to try replacing the dock and seeing if that helps (I’m not hopeful that this will resolve the issue), or we need to offer you a return for a refund.

I’m hesitant to change anything right now given I have a working, though not optimal system. Is there any other way to test the port?

I totally understand, we certainly don’t want to make things worse.

The only other way to test the HDMI port would be to test this dock with another computer that can support our dock. If the dock HDMI port works with another USB-C system with USB-C DP Alt Mode support, then we’d know the dock hardware is fine and that this may be a compatibility issue, or specific issue with this laptop itself. I know that might not be something that can be tested since you may not have easy access to another compatible computer.

Otherwise, we’d need to send a replacement dock to rule out a hardware issue that way.