Lenovo X1 Carbon not working with Plugable TBT3-UDC1

Hello,

I am using the TBT3-UDC1 dock with my Lenovo X1 Carbon 6th Gen work laptop. My 2 external displays are working properly but the laptop is not detecting the ethernet cable or any USB devices plugged into the dock. I have ensured that the dock is connected to my laptop’s Thunderbolt 3 port with the Thunderbolt symbol. I have also verified that my laptop’s Thunderbolt software is up to date.

I will add that I also have a personal Lenovo Yoga 720-13IKB that works perfectly fine with this dock.

Looking for any suggestions. Thank you!

Hello abrown,

Thank you for reaching out to Plugable Support!

I am sorry to hear that you are having issues with your TBT3-UDC1 docking station, but I would be happy to help diagnose the issue.

Based on your problem description, this sounds like this could be a Thunderbolt authentication issue. We have detailed article on Thunderbolt authentication here, but I can give you the short rundown of what to look for.

Search the Start Menu for Thunderbolt Control Center and open the application. You should see a screen that looks similar to this, which I took from our article.

If the Thunderbolt device is authenticated, it will say “Connected” in the Connection Status section on the bottom of the screen.

If it says “Not connected” like it does in the picture, please follow the instructions on our Thunderbolt 3 Authentication article to authenticate your dock.

Please let me know if the dock is connected but you are still having issues with the USB and Ethernet.

Thank you for allowing us to help!

Evan
Plugable Technologies
www.plugable.com/support