Lenovo Windows 7 Does not find drivers for USB 2.0 Hub (MTT)


#1

Hey!

I installed the drivers on the CD, and the also from the websites (Display Link) and Asix.

My laptop will not recognize the device and keeps saying it cannot find the drivers!


#2

Hi Aditya,

Thanks for contacting Plugable Support, we’ll be happy to help. I just have a couple of questions about the rest of the hardware in the Docking Station. Is the external monitor working? Does the ethernet adapter in the Docking Station work? How about the USB ports? If you plug a simple USB device like a mouse or keyboard into one of the USB ports on the Docking station, does it work?

Let me know these additional details and we’ll figure out our next steps.

Thanks,
Jerome.


#3

Thanks for the reply.

I just got the dock yesterday and I am just trying for the computer to recognize it. When I plug the dock to my USB, without anything hooked on, Windows tries to find the drivers and then tells me it could not find drivers for it.

I have not even tried hooking things up yet!

I did install the software from the CD (x64 bit) before I hooked up the device in hopes it would find the drivers installed.

Adi


#4

Hi Aditya,

Try connecting some things to your Docking Station like USB thumb drives or a mouse or keyboard, then try connecting an external monitor to the Docking Station.

Do they work?

Jerome.


#5

They do not.


#6

Thanks for checking on that for me. Just one more question, as a double check, can you say if the blue light is on or if the green light comes on when you plug in a USB device? If so, do you have another computer you could try the docking station on?

If the lights do not come on, please forward your Amazon Order id and the serial number of the unit you have over to us at support@plugable.com.

We’ll get you up and running!
Thanks for your patience,
Jerome.

Plugable Technologies


#7

I see a blue light.

Adi


#8

Hi Aditya,

So no green light when you plug in a USB flash drive or mouse? It sounds like a hardware problem. Shoot us an email to support@plugable.com with your Amazon Order ID, the serial number of your device and confirmation of a good address to ship a replacement to and we’ll get you fixed up.

Thanks,
Jerome Myers

Plugable Technologies


#9

Thanks Jerome!

Will do!

Adi


#10

Thank you.


#11

Jerome,

I got the new device and the same result.

When I do got device manager, Windows indicates that it cannot find the drivers for this device.

I then installed the drivers from the plugable website and still the same result. !](https://d37wxxhohlp07s.cloudfront.net/s3_images/760445/Drivers_Installed_inline.jpg?1341591636)](https://d37wxxhohlp07s.cloudfront.net/s3_images/760445/Drivers_Installed.jpg?1341591636) !](https://d37wxxhohlp07s.cloudfront.net/s3_images/760446/Device_Driver_Img_inline.jpg?1341591645)](https://d37wxxhohlp07s.cloudfront.net/s3_images/760446/Device_Driver_Img.jpg?1341591645)


#12

Hi Aditya,

Sorry to hear that the new Docking Station didn’t fix your issue. Because hub drivers are built into Windows and we know that your hardware is functional it’s looking like your installation of Windows is having an issue. To narrow it down, let’s try a few things.

  1. What is the make and model of computer and which version of Windows do you have?

  2. Do you have any other USB ports you can plug into? Make sure you are connecting directly to the computer, not through a hub.

  3. run this command from a command prompt and send the file that it creates and places on your desktop to support@plugable.com.

dir inf*usb* system32\drivers*usb* > %homepath%\desktop\usbfiles.txt

We’ll look for your answers to the first two questions and the usb files so we can get a better idea of what’s going on with your system.

Thanks,
Jerome.


#13
  1. Lenovo Y560p, Windows 7 Ultimate, SP1 x64 bit w/ Intel i7-2630Qm
  2. I tried all 4 of them. After connecting, I had to sometimes go to device manager and kick off the “find hardware” …

I have sent the file to the support email

Thanks,
Adi


#14

For the benefit of others,

This issue was resolved by replacing a missing usb.inf file.


#15