Lenovo Carbon X1 - Plugable Docking Station Issues

Recently, my Plugable docking station is working inconsistently with both Thunderbolt ports after a BIOS update. I have to reboot multiple times, insert, remove and reinsert the Thunderbolt cable, and sometimes open/close the laptop lid multiple times before my monitors work. I used to be able to just press the laptop power button, close the cover and things worked fine. The picture is one example of what I see on one monitor, while the other is just blank. I fully power down at the end of each work day. I’ve also tried another Thunderbolt cable (same result). I’ve verified the Thunderbolt Control Center doesn’t show it as an unapproved device. When it works, it shows the correct name and model.

Any ideas?

Hello Dan,

Thank you for reaching out on the forums!

I am sorry to hear that you are running into issues with your TBT4-UDZ, but I would be happy to help diagnose the issue here.

Some steps we’ll want to take are to perform a power-cycle of the unit to reset its internal hub chipset. We’ve seen that this can often restore the dock back to a working state when one or more of its functions are not quite working. To do this, please follow these steps:

  1. Disconnect all USB peripherals and displays connected to the dock
  2. Disconnect the docking station from host machine, then disconnect the power adapter from power
  3. Leave unplugged for 1 minute for power to dissipate
  4. Connect docking station initially into power only
  5. Connect docking station to host machine, then connect USB peripherals and displays, then test for functionality

Please let me know if this helps at all.

If this doesn’t help, I’d like to request that you reach out to us directly at support@plugable.com so we can do further troubleshooting. In the subject of your direct email, please reference case 416248 which will allow us to match things up and then provide the next steps.

Thank you,

Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.