Latest DisplayLink drivers don't work with new USB 3.0 UGA multiple display adapter


#1

Hey Bernie,

The latest DisplayLink drivers don’t work with the new USB 3.0 UGA multiple display adapter. Whether installing through the update utility that runs after installing the drivers from the CD yielding version 6.2.37054 or a fresh install from http://plugable.com/drivers/displaylink/ yielding version 6.2.37544, the outcome is the same. Blank screen and no DisplayLink utility displayed in the system tray. However, version 6.1.36490 which comes on the CD does work as long as you make sure to enable the Interactive Services Detection service.

Windows 7
Plugable USB 3.0 PCI-E Card
Plugable USB 3.0 UGA multiple display adapter

Thanks,
Brad


#2

Hi Brad,

Thanks so much for this report! With a new product like this, we want to make sure to iron out any issues!

The Interactive Services Detection service (which is enabled by default in Windows) is one of the dependencies of the DisplayLink drivers. Now that you have that re-enabled, is there any chance that the 6.2 driver install works now?

Thanks for letting us know – we’re running 6.2 with the adapter here, and will try to track down how we can recreate this.

Thanks again!!
Bernie


#3

Hey Bernie,

I tried both the fresh 6.2 install and the 6.2 upgrade with Interactive Services Detection service started, but neither worked. For some strange reason now the 6.1 doesn’t work either. When installing 6.1 from the CD or 6.2 from your website, Windows errors after I plug in the adapter into the USB 3.0 desktop card. It errors when trying to add the devices with errors “Device is unplugged.” but all connections are secure. When uninstalling the drivers, I leave the cable disconnected and I reboot. When installing the drivers, I also leave the cable disconnected and reboot before plugging the cable back in. Then I receive the error. After the error, I unplugged the USB cable and plugged it into the 2nd USB port. The DisplayLink software pops up for some reason and says please wait while it updates the device but it goes away and the device is still not added. I reboot again and the device is still not added. Any ideas?

Thanks,
Brad


#4

Hi Brad,

If you’re able, we’d like to see what DisplayLink’s logs are showing of the situation. Can you run the support tool, and email the .zip files it generates to us at support@plugable.com?

Here’s how: http://plugable.com/support/tools/dis…

This may clarify what’s different about this setup. Thanks so much!
Bernie


#5

The logs are on their way.

Also, I’m getting the following error periodically in the Windows System log. The service is enabled.

The DisplayLinkManager service is marked as an interactive service. However, the system is configured to not allow interactive services. This service may not function properly.


#6

Hey Bernie,

I did some more research and found the SIIG USB 3.0 4 port PCIe x1 card which includes the more stable TI chipset. Product link below:

http://www.newegg.com/Product/Product…

This card works perfect with all 3 Plugable USB 3.0 video adapters connected simultaneously. I added a TrippLite USB 3.0 hub and after following the helpful advice on Plugable’s website on how to upgrade the VIA chipset firmware to the latest release (which is very stable) I am up and running. I will be adding one more hub so that I can connect all of my other USB devices (keyboard, touchpad, etc.) as well. Once that is complete, I will have only one USB 3.0 cable to plug into any computer which will instantaneously switch all devices to the connected PC. In a word, sweet!

Thanks for all of your help over the past month! I couldn’t have asked for better customer service and I’m happy to be new Plugable customer.

Best regards,
Brad


#7

Thanks again Brad! It’s great to have you up and running!


#8