LaCie USB 2.0 Hub Failed with UGA


#1

I added a Plugable UGA adapter to my MacBook (OS/X 10.5.8), installed the drivers and the display works. But now my LaCie USB 2.0 hub does not!! How can I fix this?


#2

Hi Henry,

Thanks for posting! We’ll need more details to understand what’s happening.

Each USB device consumes additional power from the bus (up to 500mA), and so a common problem is to exceed the amount of power available (if the MacBook has 2 USB ports on it, it must supply up to 1A, but may supply more).

A few questions to understand better:

  1. It sounds from the behavior that the LaCie USB 2.0 hub is bus powered (that is, it doesn’t have its own AC adapter). Is that correct?

  2. Can you say what devices you have connected to the LaCie hub? And what USB devices connected directly to the Mac? Which ones aren’t working?

We’ll figure out what’s happening. If power to too many devices is the problem, you may need a powered USB hub to get all the devices you have working.

Thanks again for posting this additional info!
Bernie


#3

Sorry I wasn’t more clear. The UGA adapter is plugged into one of my MacBook’s two USB ports. The LaCie hub is plugged into the other MacBook USB port.

The hub is powered and provides 7 USB 2.0 ports. I’m only using 2 of the 7 ports on the hub. One is for my Apple USB keyboard and the other is a Kensington trackball. (not big power draws)

I’ve tried switching ports with no success. Even though the LaCie hub is brand new, I’m beginning to think that it has failed somehow.

Any suggestions would be appreciated. Thanks.


#4

Hi Henry,

Thanks for the additional detail! One thing I’d double check - the Mac can disable USB ports when there’s been an error, so I’d swap which ports the USB graphics and the hub are connected to, to confirm. If that’s it, a reboot should help.

Also make sure to double-check USB and power connections to the hub.

Assuming that’s not it, given the simple devices being attached, it may be that the hub has failed. If you’re in your return period, I’d do that.

There’s real no way for a device (especially one without its own AC power) on one port of the MacBook to affect the hub an another.

And plugging devices into a hub shouldn’t ever hurt the hub (the hub should be designed to handle things).

Unfortunately, despite that, hubs or ports on hubs going bad is not uncommon with some hub chipsets (which is why we try to stick with NEC or Terminus Technology chipsets for our Plugable hubs, which we find to be the best). I don’t know what’s in the LaCie.

Let us know if any of these double-checks turn up anything, or if you turn up any other datapoints. Thanks for your patience and let us know if we can do anything to help!

Thank you!
Bernie


#5

I tried swapping the ports but it made no difference. Rebooting didn’t help either. Neither did cleaning the Mac’s caches.

I have to assume that the hub itself has failed. I’m surprised, as I’ve only had it a couple weeks. I’ve contacted the manufacturer and am arranging to return it.

Turns out this problem has nothing to do with the Plugable adapter. I’m glad for that!

Thanks!


#6

Just a quick pitch for our Plugable hubs: they’re both self powered (that is, come with AC adapters), they use Terminus Technology chipsets – which we think is the best USB 2.0 chipset out there right now especially for handling power issues, and both have thoughtful design features – the 7 port, in particular, has per-port LEDs which help diagnose any problems. See http://plugable.com/products/hubs/ for details.

Thanks for your patience in working through and figuring out what was happening there!


#7