Keyboard doesn't work when Multipoint 2011 loads


#1

I cannot get keyboards to work on MultiPoint 2011 when trying to use them through. The mice work just fine. Any ideas?

Multipoint will ask to “Press C” (or some other letter) to begin session, and the keyboard will activate that but will not allow me to type in anything into the username and password fields.

The mouse still works.


#2

Hi Matt,

Thanks for posting! Can you say what model of USB terminal / zero client you’re using? And what make/model of keyboard?

It’s interesting that that pressing the first key activates the session, but that other keypresses after don’t work …

Thanks for letting us know, we’ll work to help.

Bernie


#3

Thanks for asking those questions.

I am using the Plugable DC-125. The keyboard is a Dell SK-8125. I tried multiple keyboards, but they were all the same model.

Since you asked that question, I tried a non Dell keyboard and everything works. This is bizarre. Thanks for your help and I will let you know if there are any more problems.

Matt


#4

Hi Matt,

Ah, that’s it. The Dell SK-8125 keyboard has a USB hub inside it (with two downstream ports). So that hub controller plus the extra ports, plus everything already on the DC-125 is more power than a single USB port provides.

You’ll be fine with all standard USB keyboards (those without more downstream devices which take power).

Hope that helps. Once you have things up and running, we’d love to hear how the overall setup is working for you. Let us know if you have any questions!

Thanks,
Bernie


#5

Thanks for being very responsive.

I am going to buy keyboards in bulk to fill up the lab. Does the LITE-ON SK-1688U/B work well? It doesn’t seem to have any bells or whistles so I’m anticipating it not using a lot of power.


#6

Hi Matt,

Yep, that keyboard will work great. And any spares you have around will work too, as long as they don’t have a USB hub (they’re just a keyboard device, nothing more).

Thanks!
Bernie


#7