Keep getting "No signal" on the screen for Plugable USB 2.0 Multiseat Thin Client with DisplayLink DVI/VGA up to 1920x1080"


#1

Just got from Amazon a “Plugable USB 2.0 Multiseat Thin Client with DisplayLink DVI/VGA up to 1920x1080, Audio, and 4 Available High-Speed USB 2.0 Ports”. I tried to use it with Fedora 17 x64, but frequently got “no signal” on the display, whenever I tried to play video or some times out of no reason. I tried “fall back” mode, no use. Any one knows why?

By the way, my computer is an Intel i5. Performance wise, should not be a problem.

Thanks in advance for your kind help.


#2

Hi Jinming,

Thanks for posting. ‘No signal’ on the monitor after things have been working well for a while, would might be most likely caused by a loose cable connection. Can you say if your’re using dvi or vga connection to the ud-160-m HTTP://Plugable.com/products/ud-160-m ? How long is that cable?

Thanks! With that, we’ll figure out next steps.

Bernie


#3

Hi Bernie,

The cable is of regular length, around 1 meter. I tried both DVI and VGA connections, all ending up with the same results.

When I connected the device and turned on the power, the login screen poped up and worked well. But once logged in, it did not take a while to get the “no signal” or a green screen. Many things seemed to be able to trick that, such as a log in the primary seat.

I used F17 X64 gnome 3. Tried the stardard and fall back modes.

Thanks,
Jinming


#4

Hi Bernie,

I changed the USB port on my PC and now everything works fine. I think that I might have used a faulty USB port. It works great now!

Thank you very much for your help.

Jinming


#5

Hi Jinming - Thanks for sticking with it to a solution! It’s great to have an explanation for why the screen was coming and going, after the Linux desktop had already come up – we hadn’t seen that before. But that now makes sense.

Thanks and glad to have you up and running! By the way, how many USB terminals (http://plugable.com/products/ud-160-m/ ) are you running now, and how many do you plan to go up to?

Best wishes!
Bernie


#6

Hi Bernie,

I am running one at the moment. May run two more in the future. When will you release a usb 3.0 version for Linux?

I tried F17 with LXDE. It did not work for me. Is Gnome the only UI for Fedora so far?

Thanks,
Jinming


#7

Hi Jinming - The solution will stay with USB 2.0 for quite a while. It’s both because of different protocols to the chips and because USB 3.0 has shorter cable length limits (in theory and even more in practice).

Yes, it’s only GNOME today. Once others get integration with systemd (which has the key “glue” that makes automatic USB multiseat work), they can also begin working.

Thanks!
Bernie


#8