Jerky mouse when plugged into UD-CA1

I’m just setting up my new Dell XPS 13 laptop with a UD-CA1 dock. When I have the mouse plugged into the dock, and the mouse pointer is moved around the screen continuously, the pointer freezes every 2-3 seconds for half a second, making the movement appear jerky. When I plug the mouse directly into the laptop, the pointer movement is smooth. I’ve tried this with my regular Logitech MX1000 wireless mouse, and a wired Logitech MX500 mouse. I have tried the front USB3 ports and the rear USB2 ports on the UD-CA1. It’s a new computer so I haven’t loaded any mouse software yet. Any ideas of what else I could try? I’d like to have the mouse plugged into the dock because I take my laptop home every night.


Hi Martin, thanks for posting and for the description of the issue you are seeing. Based off of this, and as a temporary test, would you be able to adjust the WiFi power settings within Windows to a lower percentage? We have noticed on some Dell XPS systems when using USB Type C products that performance can become undesirable due to a wireless interference issue. The strange thing is that the behavior does not seem to affect all machines even of the same model. We’ve written about our findings in a blog post here –>… if interested.

To summarize in short, we have found that lowering the WiFi power settings on some machines seems to help the performance. Would you be able to test this by walking through the steps at the bottom of the article here –>… and let us know if you experience any difference?

If lowering the WiFi power output, would you be able to test temporarily setting you system to Airplane Mode to see if things appear different?

Please let us know the results of these tests whenever you have a moment and we’ll go from there.

Thank you,

David W.
Plugable Technologies

Hi David, thanks for the reply. Lots of reading in those links! I put the laptop into airplane mode and then plugged my keyboard/mouse into the UD-CA1 and the problem went away! So naturally I wanted to see if the problem came back when out of airplane mode, so I unplugged the dock, turned off airplane mode and made sure I was accessing the network via wifi, then plugged the dock back in, and the problem has still not re-appeared.

I should note that I have the XPS 13 9360, which has a “Killer Wireless-n/a/ac 1535” adapter, and on the advanced properties on that device there is no “Power Output” setting. I’ll post my findings in that thread as well, and reply to this topic if anything changes.

Further update, the jerky mouse problem came back when the system had to reboot for an update. I put it into airplane mode and the problem went away. So it seems that if the dock could automatically put the system into airplane mode, or at least turn off the wifi when it’s connected (who needs wifi when you have a wired connection on the dock?) that would be a good fix.

Further update:
As posted in another thread on this site, I downloaded this patch:…
which adds this registry key:
And the problem went away, I don’t have to worry about putting it into airplane mode. Hopefully it hasn’t affected anything else.