It couldn't work even after downloaded the driver!


#1

I bought plugable USB 3.0 Gigabit Ethernet Adapter, USB3-E1000. Because I use mac-book air and there is no WIFI in my apartment. I am sure that the Ethernet is available. I only need an adapter.
I use Windows 8 and OS systems in my Mac-book air. I downloaded the driver on both systems (driver for windows in windows 8, driver for OS in OS system), but nothing happened after I plugged the adapter… It couldn’t work at all…
I tried on my roommate’s computer, still couldn’t work.
Is something wrong with this adapter itself??


#2

I tried it in Windows 8 system first. After I plugged the adapter, the driver didn’t install automatically. So I downloaded the driver myself, and installed it successfully. Then I reopened my computer. But nothing happened!! Nothing happened!! I still couldn’t use the Ethernet.
I checked the device manager, it shows that the adapter is working. But it doesn’t work because I still couldn’t use the Ethernet!!
Then I tried it in OS system. I downloaded the driver and installed it and reopened the computer, then it still didn’t work!!!

I thought it might be something wrong with my computer. So I tried it in my roommate’s computer, it still didn’t work!!!

Before that, I made sure that the Ethernet is good, the network cable is good, so if I still can’t use the Ethernet, there must be some problems with the adapter!


#3

Hi Danyang,

Thanks for posting here also! I just replied to the email sent for this same issue at support@plugable.com. Once we receive your reply, we will figure out the best way to resolve the issue quickly.

Regards,
Roze


#4