Issues with Plugable cable on MacOSX 10.7.4


#1

Hi everyone,
I’m trying to use a Plugable cable to connect from my Mac to my new Sokeris net6501-50 device.

I bought the USB to Serial Converte (PL2303HX chipset).
I’ve installed the drivers (md_PL2303_MacOSX10.6_dmg_v1.4.0), and rebooted.

The 2 command to see if everything is working, here below:
$ kextstat | grep prolific
138 0 0xffffff7f80794000 0x8000 0x8000 com.prolific.driver.PL2303 (2.0.0)
$ ioreg -c IOSerialBSDClient | grep usb
| | | “IOTTYBaseName” = “usbserial”
| | | “IOCalloutDevice” = “/dev/cu.usbserial”
| | | “IODialinDevice” = “/dev/tty.usbserial”
| | | “IOTTYDevice” = “usbserial”

I also see the USB-Serial Controller D in Network Settings.

I then connect the cable (with a female adapter) to my Soekris net6501 board, then I run:
$screen /dev/tty.usbserial 19200
Finally attach the power cable to the Soekeris device, but I dont’s see anything.

I also tried with Minicom, with proper drivers loaded and settings on a Virtual Machine with Linux, but same results. I should see some output from the device, but I don’t see anything.

Can you help me?

Thanks
Michele


#2

Not sure if the issue could be that the COM1 of the Soekris device (P1 in the image below)

http://wiki.soekris.info/Net6501_Inte…

Is the one I’m connecting the plugable RS232 cable to.

The other COM2 of the device (JP7) is not connected.

I’m also trying to install the Windows driver on a WinXP machine on Vmware Fusion, and try using hyperterminal from there.

Cheers
Michele


#3

On Both Windows 7-sp1 and WinXp-sp3 after installing the driver, I cannot see it on Device Manager, even when I click on “Connect Prolific USB-to-serial to this VM”.

I’ve also tried to install the driver on another Mac I have, Lion 10.7.4, and same issues (without playing with VMware).

I’m a bit lost…


#4

Hi Michelle,

Thanks for posting all the great detail, what a cool little device! Focusing on the Mac setup in your first post – It sounds like you have it installed and configured correctly driver wise.

From the link at this page: http://wiki.soekris.info/Serial_port

It looks like you’ll need a special cable between the USB to Serial adapter and the COM port on your Sokeris. Do you have a cable that routes pin two to pin six?

Let me know about that and we’ll figure out our next steps.

Thanks,
Jerome

Plugable Technologies


#5

Thanks for your reply Jerome.

So looks like I need to buy something like this:
http://www.amazon.co.uk/StarTech-Seri…

attach it to JP7 on the device board, then use the pl2303 usb-to-serial cable to attach to it, and finally it should work, right?

Let me know
Cheers
Michele


#6

Hi Michelle,

I don’t think that one will work because one of the reviewers says that it’s a straight through pinout 1-1, 2-2, 3-3 etc…

Although they also say that it’s a crimp on connector so you could change it around if you wanted so… maybe it can be made to work.

Still, with that said it would probably be best to go for one of the two that they point to directly like:

http://www.computergate.com/products/…

You’ll need to end up with a pin out like this:

DB-9 IDC-10
Pin 1 Pin 1
Pin 2 Pin 3
Pin 3 Pin 5
Pin 4 Pin 7
Pin 5 Pin 9
Pin 6 Pin 2
Pin 7 Pin 4
Pin 8 Pin 6
Pin 9 Pin 8

I hope that helps!

Let me know what you find,
Jerome.


#7

I feel dumb :smiley:

Everything is working now.

The issue was that I was connecting the plugable cable with the female adaptor straight to the device :smiley:

Adding a proper standard null modem cable did the trick!
You can mark the ticket solved, thanks for the help, really appreciated!

I confirm that the Plugable driver works perfectly on Lion 10.7.4. I’m accessing the device with $sudo screen /dev/tty.usbserial 19200

Cheers
Michele


#8

Hi Michelle,

Glad to hear you found the solution, thanks for letting us know. Have fun with your new device!

Enjoy,
Jerome

Plugable Technologies


#9