Issue using UD-3900 Docking station w/ USB3-Switch, 2 systems and 3 monitors.


#1

I recently replaced a wired KVM setup between my desktop PC and a All in one desktop/laptop with the UD-3900 Docking station and the USB3-Switch.
If I connect either system to the docking station everything works including the 3 external monitors.
But if I connect the docking station to the USB3 switch which then connects to both systems, only the desktop shows all three monitors while the all-in-one only shows 1 external monitor.

The following diagram below illustrates my setup.
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1416825/WorkConnections_inline.png?1463411889)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1416825/WorkConnections.png?1463411889)

The all-in-one is a Dell XPS 18 1820, Windows 10 64bit, 16GB with 2 USB 3.0 ports
The desktop is a Dell Optiplex 990 SFF (small form factor) with Windows 7 32bit, 16GB ram (although Windows only can access 4).
The 3 monitors are Dell D2015HM, vga output only at 1920 x 1080 resolution.

Steps that I tried to resolve the issue are as follows (on the All-In-One)…
A: Reinstalled the display link drivers.
-1:Removed/Uninstalled the DisplayLink drivers from the Control Panel/Add or Remove Programs
-2:Rebooted
-3:Removed any remaining DisplayLink drivers using the Cleaner tool.
-4:Rebooted
-5:Reinstalled the Display Link drivers.

B:Check each individual monitor cable
-1:Even though all monitors work when the Docking port is connected directly to either system, I still went ahead and checked each cable.
-2:I checked the UBS3-Switch cables by connecting/switching them to the desktop.

Now after performing the above steps, I reconnected the UD-3900 to the USB3-Switch and had the cables from that device going to both systems as originally done and the same issue happens. I cannot get all three monitors to show up when I switch to the All -in-one (except 1), but they all do show up when I switch over to the Desktop.

Could it be that the USB3-Switch is not working properly or it is something else entirely.
Any advise?


#2

Hi David,

Thanks for posting! Sorry to hear that your All-in-One PC is not working as expected while using with the USB switch and our dock and I will be happy to help!

Thank you for the great detail you provide in outlining your setup and describing the behavior you are seeing. Based on your description and troubleshoot steps, it certainly seems like the issue lies with our USB3 Switch as you have confirmed that our dock works while connected directly to both of your PCs. A quick way to test our USB3 switch is to connect a simple USB device to the USB input port on the USB3 switch (like a keyboard or mouse) and see if the simple device can be switched between your two computers. Does the USB3 switch work with a simple device connected?

Pending the results from that test, could you confirm if you are using the USB 3.0 cable that came with our switch to connect to your All-in-One PC? Sometimes if different or longer USB 3.0 cables are in use it could be problematic, longer cables especially.

Please let us know this additional information when you have a chance and we will determine next steps from there

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3

Hi David W.,

I cannot connect any device to the USB3-Switch like a keyboard or mouse since the 2 connection ports leading out of the USB3-Switch are the UBS3 Standard-B plug type and I have no other devices with that plug end to insert into the USB3-Switch to test out.
I did manage to log the connections for troubleshooting purposes below.
As I mentioned previously (and is so strange) is the fact that if the Dock is connected directly to either the All-In-One (AIO) tablet or the Desktop, the dock works fine with all monitors, keyboard and mouse working. But when the dock is connected to the USB3-Switch, only the keyboard and mouse work when connected to the AIO Tablet. When it is connected to the Desktop they all work.

See image below.
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1417381/Plugable-Troubleshooting1_inline.png?1463497090)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1417381/Plugable-Troubleshooting1.png?1463497090)

Now looking over at the Device manager images of both systems,
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1417386/Plugable-DeviceManager_inline.png?1463497532)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1417386/Plugable-DeviceManager.png?1463497532)
it seems that when the dock is connected directly to the the AIO or the Desktop, both the Plugable UD-3900 dock and UGA-3000 adapter show up. (As shown on the left part of the image below), Those two devices also show up when connected to the desktop via the USB3-Switch. But they do not show up when I switch over to the AIO (as seen on the right side of the image).

So at this point I am back to square one where I cannot tell if it is the USB3-Switch or the AIO device drivers not being accepted or the Dock itself.

Oh, btw I also tried to manually add the Plugable Display Link Display Adapter drivers but that didn’t change anything. The AIO still cannot connect to the monitors.

edit: forgot to mention that Yes I am using all the supplied USB3 cables that came with the devices (UD-3900 and USB3-Switch) Although the cable going from the UD-3900 is thinner than the ones that came with the USB3-switch.

Hope you can help , thanks
Dave


#4

Hi Dave,

Thanks for the update and providing this great detail. In regards to testing a simple device while using the USB3 switch, I was referring to connecting a USB keyboard or mouse to the USB type A input of the switch (where your UD-3900 is currently connected). Would you be able to let us know if the attached USB device can be switched from your desktop to all-in-one PC?

Given that you have tested our dock and adapter connected directly to each system and they work properly would be lead to believe that the issue lies with the USB3 switch, so testing with a simple USB device is important to see if it is able to be used on both PCs white using the switch.

Pending the results of that test, we may want to send you a replacement switch to make sure that the hardware is functioning properly. Please reach out to our direct support Email address at support@plugable.com and reference Ticket number #142201 so we can match everything up.

Thank you for your patience,

David W.


#5

Hi Dave,

I do apologize as I misinterpreted your tests when reading your description and looking at the chart you sent. Based on the chart, I have a theory this could be an issue related to USB 3.0 cable degradation due to length that is isolated to only your All in one PC. As a test, would it be possible to try another available USB 3.0 port on your All in One from our switch, if you haven’t already? Also, if possible, would you be able to test connecting from the USB B output port on our switch with a USB 2.0 standard cable to your All in One PC? USB 2.0 is not as restrictive on cable length as USB 3.0, so curious if an older standard of USB cable will behave in the same manner.

Also, would you be able to even test connecting a different system to this set up in lieu of your All in one PC? I am curious if we are able to reproduce this behavior on a separate PC in your desired setup.

I do apologize for any confusion and thank you for your patience!

David W.


#6

Hi,

Yesterday, as requested, I connected the USB mouse to the USB Type A input and it showed up on the AIO. (That was on switch 2), It also worked on Switch 1 of the USB3-Switch that connects to the Desktop.

As for testing on another USB port on the AIO, that was also done. Directly connected to the Dock works fine, connected to the USB Switch, no monitors show up on either of the two available USB 3.0 ports on the AIO.

Unfortunately, I am unable to performed your request to connect a USB 2.0 cable to the Type A port of the USB3-Switch since I do not have a Type A to Type A USB cable. I thought I had one, but I guess I don’t.

Now there is a new head-scratching issue.
I decided to connect a Sony Vaio Flip 13 A laptop to one of the outgoing USB3-Switch cables, the other to the Dell AIO. The USB3-Switch is connected to the UD-3900 dock.
Results on this test.
All monitors show up when switched over to the Sony Laptop but not the Dell AIO.
(Regardless of cable I use).
I then Connected the Dell Optiplex 990 SFF PC and the Sony Vaio Laptop.
All monitors show up on either switched system.

I would think it has something to do with the Dell AIO but when the dock is connected directly to it, all monitors work.
I am truly stumped at this point.

In the meantime I will send support a link this thread along with the Ticket number you gave me and seek further instructions.

Thanks
Dave


#7

Just posting a follow-up in case anyone else comes across this issue…

After a few emails with tech support trying to troubleshoot, It seems that the fault lies in either one of the cables or the USB 3.0 port on the AIO. Updated all drivers on the AIO and I went ahead and bought a few USB Type A to Type B USB 3.0 cables to test out each OEM one. It seems that the USB cable going from the Dock to the USB3-Switch was the culprit. It has now been replaced and both systems are working properly.
So if anyone else has this type of setup and comes across a similar issue, try to check and or swap out the cables.

Thanks to David W of Plugable support for helping me troubleshoot.
Issue is resolved.


#8