Installer Not Working

The monitor connected via my Plugable USB3-VGA DisplayLink was freezing up or going blank.

I upgraded the drivers to 9.2.2057.

Then I had problems with the DisplayLink and monitor again.

I downloaded and tried to install:


The first install seemed to work. I got messages like “Setting up…”, “Device is ready”.

But I still had problems.

I tried another install. But the progress bar displays for 4-6 minutes. And nothing happens.

Then if I reboot the DisplayLink driver reverts back to 9.1.1644.0.

Should I just upgrade to a new Plugable device?

I have:
Lenovo P50
Windows 10 Pro
2TB hard drive.

Thanks for reaching out!

We’ll want to proceed with a clean installation of the drivers, and see if the behavior is any different. Please do all of the following with the DisplayLink device disconnected, until the very last step.

  1. Disconnect the DisplayLink adapter from the computer
  2. Uninstall DisplayLink Core software from Control Panel > Programs. Don’t worry if this fails, just move onto the next step
  3. Download and run the DisplayLink cleaner tool, found here:

  1. Once the Cleaner has been run, reboot (even if not prompted to)
  2. Now download and run the latest DisplayLink software, found here:

  1. Reboot, even if not prompted to
  2. Once you’re back in Windows, reattach the DisplayLink adapter and let it install and update the firmware which should happen automatically.

Let me know if that helps!

Hey Sam,

Thank you for the instructions. I followed them step-by-step.

When I plugged my DisplayLink USB 3.0 Adapter back into my system I heard the dings indicating that Windows recognized the adapter and my 2nd monitor went on.

However, I didn’t see any messages that firmware was updated.

I looked at the Driver info and here’s what I see (below)

As far as I know 9.2.2420 is the latest Windows driver. So I think that is up-to-date now.

The 2nd monitor display was freezing every few days. So I’ll have to watch the monitor for a few days to make sure everything is stable.

If I run into more problems I’ll be in touch.

Thanks again for your help!


Glad to hear that helped!

If you do hit any issues, do reach back out here. This topic will close automatically after 20 days, but you can always reach out through email at as well and mention this topic!

HI Sam,

This morning I discovered my laptop was running very sluggishly. I managed to open Task Manager. I saw that System Interrupts was taking up 91% or more of the CPU.

I unplugged the DisplayLink from my USB hub. Then I rebooted my laptop. Things seem to be running fine now.

This is an entry from Event Viewer 8:43 AM:

The device Plugable USB3-VGA (location 0000.0014.0000. is offline due to a user-mode driver crash. Windows will attempt to restart the device 1 more times. Please contact the device manufacturer for more information about this problem.

I see about 15 of these entries for this morning.

I’m sorry to hear you’re still having issues. This is pretty strange behavior, and I’d like to grab logs from your system to see what’s going on.

Could you run our support tool, Plugdebug, and send me the resulting .zip archive? I’ll follow up with a direct email so you have somewhere to send that!

After parsing @CoolBreeze helpfully sent over, it was pretty clear that the DisplayLink drivers had been corrupted for a second time. A subsequent clean install of the drivers fixed the issue.

If anyone comes across this and has had similar issues that a repeat clean install doesn’t help with, please do reach out to with logs so we can help!