Installed new Plugable. No display on two ext monitors. Win 10 with Toshiba Satellite laptop

Window has stopped this device because it has reported problems (code 43)

We resolved this problem via email. For anybody else having similar issues this was the resolution. Please feel free to email us directly: support@plugable.com

The resolution was to: reset the dock and perform a ‘clean’ installation of the required DisplayLink drivers to help ensure both are in a good state. Please perform the following:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download and run the DisplayLink Installation Cleaner utility, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.4 M0 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system. If the device is not detected, please reboot the system.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support