I think your USB-C hub just killed my Macbook Pro 13 (non-touch function)


#1

I just tried to dock my Macbook Pro to the USB-C hub that I received yesterday from Amazon. One thing I noticed when opening the box is that the seal had already been broken.

So anyways got it setup yesterday, had a few issues getting it to work but it finally did. Got ethernet working and was even able to connect my USB-C G-Drive to the dock so that it would auto connect.

Came home tonight from Starbucks, where I had put the Macbook asleep since I figured it would be easier to reconnect to the hub. Plugged it in, heard the Macbook give the power connection chime. I then heard the audio on my monitor sound like it reset. Macbook had work up but the OS is complaing that the G-Drive wasn’t disconnected properly. Unplugged the Macbook and plugged it back it, same thing. Unplugged the Macbook and forced it to power off. Plugged it back in to the dock and tried to power it on. Macbook now won’t power on. Unplugged the Macbook from the dock and still won’t power on. Plugged the Macbook into the Apple power adapter, no power connection chime and still won’t power on.

After messing around with the Macbook, I got it back up and running but I’m a little nervous about plugging back into this dock.


#2

Hi Jeff,

Thanks for contacting Plugable support. Sorry to hear about this issue, I’d be happy to help.

You say that you think our dock killed your MacBook, but you also say that after working with it for a while it’s now up and running? Can you confirm if the laptop is damaged or not as best you can tell currently?

Next, because the dock appeared to be opened already when you got it, please do not connect the dock back to the laptop. We’ll want to find out why you got what looks like a used dock. Can you contact support@plugable.com with your Amazon Order ID, serial # off the bottom of the dock, and the best shipping address? Also on the back of the dock near the power input, does it say 20C or 20V?

Thank you,
Joshua Henry
Plugable Technologies


#3

Hi Josh,
It seems to be okay now but it was really freaked out over whatever happened.

The power connector says 20V.

I just sent the rest of the information over in the email.

Thanks for taking a look at this.


#4