I installed the latest driver for Win7. It said the driver installed,but nothing happens when I plug in the cable.


#1

I am running Win7 Ultimate on a Dell XPS 13 Ultrabook. I checked the Network and Sharing Center - nothing. I looked in Device Manager and it showed up as Other Devices… Unknown Device. I tried Update Driver Software and pointed to the driver folder but Windows said it’s unable to install the driver. I deleted the unknown device, restarted my computer and tried again with the same results.

This is very frustrating because the $6 USB to ethernet device I got from eBay worked fine (until I bumped it and broke it). I bought the plugable device because it looks more versatile and durable.


#2

Hi Bruce,

Sorry for the frustration. There are different drivers for our 10/100 adapter and Gigabit adapter (even though both use ASIX chipsets).

You can get the latest drivers at http://plugable.com/drivers/

Once the drivers are installed, the adapter should no longer show up as “unknown device” when plugged in. Please reply back if that’s the case, and we’ll be able to figure out what’s wrong.

Thanks for your patience!
Bernie


#3

I am attempting to use the Plugable USB2-E1000 (ASIX AX88178) . I read all of the other Windows 7 messages about this device and already followed the instructions, using AX88178_Windows7_v1.x.3.8_Drivers_Setup_v1.0.1.0.zip. I have redone this 3 times, carefully following all instructions and it still does not work.


#4

Hi Bruce - we’ll figure out what’s wrong. We have thousands of users on Windows 7 with this adapter, running those drivers. So there’s something special going on here that we need to identify to get you up and running.

Two quick questions:

  1. Do you still see an “Other Devices… Unknown Device” in device manager? If so, does that unknown device disappear when you unplug the gigabit ethernet adapter?

  2. I assume this is a new adapter and you’ve never had it working, is that right? If so, do you have another machine nearby that you could install the driver and test the adapter on?

Thanks for your patience and this additional information - we’ll figure out what’s wrong. We want to get you up and running as quickly as possible!

Bernie


#5