I have a plugable VGA /DVI/ HDMI adapterwith no power (Green) Light


#1

NO Green Light on Adapter


#2

Hi John,

Thanks for posting here! I’m sorry to know that you are having trouble with the Plugable UGA-2K-A. The green LED on the adapter does not light up when:

  1. The unit does not receive enough power because it is plugged into a port that does not provide the required 500mA of power or because of a failing USB Cable

  2. Display to that monitor is disabled

  3. The driver has got corrupted

  4. The unit itself has failed.

Some quick questions to understand the setup and the issue better:

  1. What is the make and model of the system to which the Plugable UGA-2K-A is connected and what is the current version of OS used?

2)What is the make and model of the monitor connected through the Plugable UGA-2K-A and is it connected through VGA, DVI or HDMI?

  1. Is the Plugable UGA-2K-A connected to the system via a hub or is it connected to an inbuilt USB port on the system? If it is connected through a hub,is the hub self powered (does it have its own power adapter that is powering it up)?

  2. If you unplug the adapter and connect it to another inbuilt USB port on the system, does the Green LED light up?

  3. Connect the Plugable UGA-2K-A to the system and run the DisplayLink Support tool (instructions here: http://plugable.com/support/displayli… ) and email the resulting .zip to support@plugable.com as an attachment along with your Amazon Order ID and link to this thread? This would give us a better insight as to what is going on.

Once you reply with this information, we can figure out the next steps.

Regards,
Roze


#3