I cant see the mouse pointer when i use my UGA-2K-A.


#1

The mouse pointer only shows up on the display connected to the UGA-2K-A and not the other 2 native displays. Please help


#2

Windows 7 64-bit OS.


#3

Hi Geoff,

Thanks for posting!

First, let’s double-check the simplest possible thing (because it’s a surprisingly common source of confusion) - can you bounce the mouse off both the left and right sides of the monitor where you can see it, and make sure that the mouse does not show up on either of the other two monitors?

It’s often confusing when the physical position of the monitors is different from the “virtual” position that Windows has them configured in. If that’s it, just open the Win 7 “Screen Resolution” control panel and drag the monitor images around until they match your physical setup.

If that doesn’t appear to work, can you confirm that when you drag windows from the monitor you can see to either of the other two, that the windows are visible on the other monitors, but the mouse is not? Or are neither windows nor mouse pointer visible?

Again, thanks for posting and for replying with results on these simpler first steps - we’ll get this figured out!

Thank you,
Bernie


#4

I can confirm that the mouse moves to all monitors because I have the windows option enabled that allows me to see its location by pressing ctrl (as described here: http://maximumpcguides.com/windows-7/…). I just can’t see it, unless it is on the monitor hooked to the UGA-2K-A.

Also, windows, icons, taskbar, etc. can be seen on all monitors. I am unable to drag windows at all, because I can’t see the mouse pointer, and thus can’t use the mouse.


#5

Enabling the pointer trails worked. Thanks.

I have and NVIDIA GeForce GTS 250 with driver version 8.17.11.9732.


#6

Hi Geoff,

Getting back to the long-term fix, we’re suspecting this is a interaction between nVidia and DisplayLink driver versions. You could stick with the mouse trails workaround, or if you’d like to work on this more, what we’d recommend trying these two updates (disabling the mouse trails workaround after each one to see if the update resolves the issue)

  1. Install the latest DisplayLink drivers from http://displaylink.com/support/downlo…
  2. Install newer nVidia drivers. We’d recommend the nVidia version 258.96 drivers (compatible with your GPU, and 64-bit since you’re on a 64-bit system): http://www.nvidia.com/object/win7-win…

If you do try these, let us know. Thanks again for your patience!
Bernie


#7

Hi Geoff,

Yep, that definitely would be frustrating! Very sorry you’ve hit this problem.

This is the first report we’ve had of something like this (which appears to be the hardware cursor on the main GPU having problems). So, let’s look for short and long term solutions.

On the short term side, on the same Win7 dialog where you set to show pointer when hitting the ctrl key (which, by the way, is a nice feature when you have many monitors) – can you also check the “display pointer trails” option and set it to a length that’s comfortable for you? Does the cursor reliably render now on all screens, moving and stopped?

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0ux4esj8N60wn0zAWgN--7gYioLdV93HbwbhWJu3UgNL29-f2551u1AZ5v8tQVPptiPomDhL4Fk2DRVtdGgL6_cQjJqLtL8kB1Qb_Q2NPkDO.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/353900/win7-mouse-pointer-options-pointer-trails-on.PNG)

And then for the long term, can you say whether you have nVidia, ATI, or Intel primary graphics, and what version of their driver? We’ll use that info to start digging in to figure out the root cause of the mouse problem.

Again, our apologies! Thanks for your patience.

Bernie


#8