I cannot find software to uninstal


#1

I have been using a USB 2 Display adaptor from Taiwan (I don’t know the manufacturer/supplier’s name) to extend the display of my Laptops & HP TouchSmart 310 PC (an all-in-one) individually to various monitors with complete success for several years. Recently I bought a VicTsing USB 3 display adaptor from YanTop EU on Amazon because I had belatedly realised I could connect more than 1 monitor to my computers. When I connected the PC to one of my monitors, it gave me a picture that was unsatisfactory for a couple of reasons, but mainly because it was a duplicate of what was on the PC screen; when I instructed it to “extend” instead of “duplicate”, the side screen went haywire, giving half a picture only and flickering like mad. So, I sent it back and expect a refund. So far so not so bad. However, now my original (USB 2) adapter won’t work with my PC any longer. So I bought a UGA-3000 to replace it. I tried downloading the software but got a message saying I must uninstall no fewer than 4 pieces of incompatible software, all of which appear to be linked to the poisonous adapter. Unfortunately, I cannot find any of these programs on my PC, so now I have yet another adapter that won’t give me what I need. Where do I go from here? I’d rather keep the new unit if it can be made to work - if only because I’m getting a new tower system in a few weeks. But I’d really like some help in identifying & eliminating the toxic download(s).


#2

Well, I found that pesky bug & uninstalled it, then I installed the software for the Plugable unit and - Hey, Presto! - everything worked fine and as expected (apart from the fact I cannot use both it and my original, fault-free unit, so I was only really back to square 1). I switched everything off & went belatedly to my bed. This morning, full of hope, I switched on again and - nothing! Nothing, that is, apart from a message telling me the software I’d downloaded for it was not up to date & was incompatible with something or other - I didn’t memorise it & don’t know how to get it back (other than, perhaps, going through the whole rigmarole of closing down everything & opening up again - life’s too short, especially at my age). What’s going on with Plugable’s stuff? Is it unfit for purpose? Do I have to send it back & start again somewhere else? HEEEEELPPPPP!!