Hub now doesn't respond.


#1

I purchased a Plugable super speed 7-port USB 3.0 Hub a few months back. It has worked fine until today. Worked fine until I shut evreyrthing off last night, now it doesn’t do anything. Nothing has changed in my hardware or software configuration. The hub seems to not power up. External power supply power light indicates AC and there is 5 V going to the hub, but nothing on the hub lights up.
I’ve tried disconnecting peripherals from the ports with no changes. What I do notice, with AC applied to the external power supply, is by connecting DC to the hub, light on ports that are connected flash briefly and then go out. They won’t come back on until DC power is removed and then power is reapplied after a short time having been disconnected. Any suggestions?
Robdoopwercd@gmail.com


#2

Hello,

Thank you for contacting Plugable support! I’d be more than happy to assist you with this issue.

I can take a quick look for a potential firmware issue and if I don’t find anything, we can send you a pretested replacement under warranty.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the hub into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Plugable Technologies


#3