Help...I need more USB ports but my puter doesn't want to cooperate!


#1

I just recieved my Plugable USB 2.0 4 port hub and fast charger with 2.5A AC power adapter. After plugging it in, the driver software installation ran and advised me the driver software was not successfully installed. The USB composite device, via telecom USB modem, via telecom USB ETS read ready to use but the INTF2 gave a message that no driver found. I ran Windows Update and found Nokia Inc - Other hardware - VIA Telecom USB HUB listed as an optional update. I ran the update but it failed to load and listed a Windows Update error 800f020b. The hub is recognizing my WD backup drive…I was able to open it from “My Computer” and retrieve a file…but it only charged my cell phone…I didn’t see it listed as a mass storage device in “My Computer”. I’m running a Dell Inspiron that is about 2 yrs old.

I’m really not all that knowledgeable when it comes to problems like this, so any help would be greatly appreciated! Thanks!

Ronni
paphappy@aol.com


#2

Hi Ronni,

Thanks for contacting us! We’ll be able to help.

The hub itself doesn’t have any “extra” drivers required - it uses the drivers built in to Windows. Windows has a special case for hubs where it doesn’t search Windows Update for new drivers – rather it always uses its own driver.

So the driver installation problems you’re seeing with the modem are specific to that modem device. One reason why you might see a problem only now, is when a device without a unique identifier (USB serial number) is moved to a new USB port (on the computer; or on a hub), Windows will re-detect and re-install the driver for a device.

Then, back to the hub … the WD drive working is good, it shows that actually the hub is working as expected there.

For the phone, it sounds like the unexpected behavior is that the phone is charging, but it’s not exposing the files on the phone via a drive on Windows (sounds like the phone is expected to have a USB mass storage interface).

So to figure out next steps:

  1. For the devices that are having trouble, can you mention the make and model of each one?
  2. And for each of them, do they work fine when connected directly to the computer?

Thanks for letting us know - we’ll be able to make sure the hub is working right, and we’ll try to help where we can with individual devices and their drivers.

Thanks again for contacting us - and whanks for your patience!
Bernie


#3

Wow…quick response! :slight_smile: Thanks for getting back to me so fast.

The cell phone is a Samsung Galaxy Nexus…brand new OS only on this phone. The OS is Android Ice Cream Sandwich version 4.0.2 It works fine plugged into the puters usb port…I can pick either Media device (MTP) or Camera (PTP) as the usb connection. I keep it on MTP to transfer music most of the time. At the same time it charges the phone.

The back-up drive is a Western Digital Passport…I’m not sure of the model but it was working fine.

These are the only things I’ve used with the plugable so far. In the future I want to be able to plug in my Nikon D90 to download pictures to my computer.

Thanks!


#4

Hi Ronni,

Thanks for this additional detail! That’s a great new phone - we’re definitely interesting in figuring out the Samsung Galaxy Nexus charging/syncing behavior.

It sounds like the phone is going into a charging-only mode when it is plugged into the hub. One interesting sign that might be the case, is if it’s charging faster through the hub, than when directly connected to the PC.

The Samsung Galaxy Nexus has some USB settings … it would be interesting to see if we can tell it to not go into this “charging only” mode when connected to a fast charging (BC 1.1) hub.

Looking at the phone manual here http://static.googleusercontent.com/e… it looks like you can reach some of the USB settings on the phone from
Settings > Device > Storage > Menu > USB computer connection

Is there any setting there which helps get the behavior you’re looking for?

Thanks for letting us know. We’d like to figure out the Galaxy Nexus settings which provide the best behavior, and would love to work with you on this.

Thanks!
Bernie


#5

I went into Settings> Device> Storage…there is no Menu after that. The catagories on the Storage page are apps; pictures & videos; Audio (music,ringtones,podcasts, etc); Downloads; Misc; Available. I don’t see anything that applies to a USB computer connection.

I did hit the little menu (3 dots) at the bottom of that page and another window popped up that was titled USB computer connection but that took me back to the same choices of MTP or PTP connection. :frowning:

As far as how fast the phone is charging from the computer vs the hub, I don’t know. The only way I could tell is to drain the battery and time it each way. I usually don’t wait till it’s down to the red to do that but will if you want.

Thanks and Happy New Year,
Ronni


#6

Hi Bernie,

Today (on a wim) I called Verizon and they told me that there is no seperate command for mass storage…the MTP and/or PTP is the mass storage command. They said the Plugable is not recognizing the mass storage or drivers are missing.

I plugged my husbands Samsung Stratosphere into the Plugable and had the same results…it didn’t recognize it either. The Stratosphere is running OS 2.3.5

The Plugable will charge both phones but my computer won’t recognize either as mass storage. :frowning:

What surprises me is that when I do plug the phone into the Plugable to charge, my computer makes that sound that it makes when I plug anything into my computer usb port (like my mouse for instance). Sorta sounds like a ‘boink’ sound…lol.

Thanks!
Ronni


#7

Hi Ronni,

Thanks so much for the detail here - it’s a huge help!

What’s apparently happening is the latest Samsung devices go into a charging-only mode when attached to a USB Battery Charging compliant hub.

That’s great (in terms of charging), but bad for sync. It’s not a limitation imposed by BC 1.1 or the hub – the standard supports 900mA charging, while simultaneously doing High Speed transfers like you would with MTP or PTP.

But the Samsung devices, at least by default, seem to think any BC 1.1 charging hub is a charging-only device.

We’re going to try to confirm this behavior and (if possible) find a setting on the phone to change it. Just to set expectations, it may take a while to get a response from Samsung.

While we do that, would there be any problems with a workaround of using the hub for charging, but plugging in directly to the PC when you want to sync? When limited to that use, is everything working as expected with the phones?

Thanks so much for your patience working with us on this!
Bernie


#8

Hi Ronni,

Thanks again. A quick question: When you plug the Samsung into the hub, does it say “Charging (USB)” or “Charging (AC)”?

This could help reinforce or steer us away from the theory above.

Thanks for letting us know if you can,
Bernie

By the way, here’s a video which shows a pre-production Samsung (unknown model) and its BC 1.1 charging behavior: https://www.youtube.com/watch?v=UhY6gW…


#9

Hi again,

I have no problem waiting…I can plug the phone into the computer if I need to. The reason I wanted the hub was to eliminate the use of the ports on the right side of my computer…the wires get in the way of my wireless mouse. :frowning: And I only have 1 port on the left side.

<<
I really appreciate all your help… :slight_smile:
Ronni


#10

Bernie,

I just noticed that my previous post is missing some of the info I wrote…not a clue why that happened.

You had asked if the phone said it was actually charging when plugged into the hub…the answer is no. I know it’s charging because there is a lightning bolt in the little battery icon. When I connect it to the computer, I also get the little USB icon (sort of looks like a pitchfork) in my notification bar. If I pull down that bar (they call it the window shade now) and i click on that icon, I can choose which MTP or PTP I want to use.

Thanks,
Ronni


#11