HDMI monitor does not work after computer wakes up


#1

I have two monitors connected to my UD-3900, connected to my laptop (Lenovo - Windows 10 Home) via USB-C. When teh computer sleeps, then wakes up, the monitor connected via DVI works, but the one connected via HDMI does not. The monitor turns on, but the display is frozen - you can’t even see the mouse on it. If I reconnect the USB cable, or change display settings on the monitor, it works again.

What can I change so that both monitors work properly upon waking up?


#2

Hi Joel,

Thanks for posting, and I would be happy to help with your docking station.

You mention you are using a UD-3900 docking station and you are connecting it to your system with a USB Type-C cable. Our UD-3900 dock doesn’t come with a USB Type-C cable, so I am a little confused. By any chance are you using our Triple Display Docking station, known as the UD-ULTCDL? That does in fact come with a USB Type-C cable. Can you confirm which dock you are using, and also what specific model number Lenovo system you have?

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

Sorry - its not USB Type-C. Its just USB 3.0 - and it is the UD-3900. I got from amazon: https://www.amazon.com/gp/product/B00….

The laptop is a Lenovo G50 Entertainment Laptop running Windows 10 Home.


#4

Hi Joel,

Thanks for getting back with the clarification. One quick thing to check is if disabling USB Selective Suspend helps. Please follow these steps:

  1. Right-click on the Start Button and select ‘Power Options’
  2. From the window that appears, for the active power plan setting, click the ‘Change plan settings’ link
  3. From the window that appears, click on the ‘Change advanced power settings’ link
  4. From the window that appears, scroll down in the list of items and expand the ‘USB Settings’ option, and then expand the ‘USB Selective Suspend setting’
  5. Change the settings for both ‘On Battery’ and ‘Plugged in’ to Disabled (example screenshot attached)
  6. Click the Apply button, and then click the OK button.
  7. Close the remaining windows and restart the system and test the behavior again.

Let us know if that helps when you have a moment, and we’ll go from there.

Thank you,

Bob !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1457454/Windows10USBSelectiveSuspend_inline.JPG?1469725541)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1457454/Windows10USBSelectiveSuspend.JPG?1469725541)


#5

Thanks - it did work the first time I tried it. Windows also just did a major update last night, so I guess that may have affected it as well.

I will return to this thread and let you know if I see the problem occur again.

Thanks for your fast response!


#6