HDMI 4K adaptor keeps disconnecting

Guys I have a couple of issues.
I bought this adaptor in March and recently it started randomly disconnecting and shifting all my windows to the other available monitor. I know this is a known issue… I re-installed the drivers, and it WAS working fine until recently (Windows 10).
I followed these steps with no avail:

The first steps we’ll want to take is to make sure that the software used by the display adaptor is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the display adaptor from the system (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ’ DisplayLink ’ in the title that is present from within the Control PanelPrograms and Features . Don’t worry if these entries are not present or if the process does not work, just move onto the next step.
  3. Download, extract and run the DisplayLink cleaner tool. (https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe )
  4. Once the Cleaner has been run, reboot (even if not prompted to).
  5. Now download and install the 9.4 M0 DisplayLink software. (https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+9.4+M0.exe )
  6. Reattach the display adaptor to your system which will trigger the final portion of the installation.

My second issue: #2

Im going to install Linux on this machine as a primary OS and I don’t know if these 4k HDMI adaptors are supported.
Is there any guide I could follow to make this work with linux? Any special drivers?

Thanks~

The steps that you mentioned are what we recommend though you will want to install the latest version of the DisplayLink driver for Windows that can be found here: https://www.displaylink.com/downloads/windows

While we do not officially support Linux, DisplayLink has a Driver that can be used: https://www.synaptics.com/products/displaylink-graphics/downloads/ubuntu

I hope this information is helpful.

Thanks for your help but I already tried re-installing and getting the latest divers.
Is there any chance you guys could exchange the faulty device?

If there is something wrong with the device itself our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug → http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 348571’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.