Graphics blurry/smaller after disconnecting from UD-3900 with computer on - Reboot fixes every time

I am running Windows 10 on a Dell M3800 laptop. I run a dual monitor setup through the Plugable UD-3900. If I unplug the laptop from the Plugable unit while the computer is on the graphics are not formatted properly (not sure if that is the correct term). The desktop icons are smaller than they normally would be and Google Chrome is very blurry. If I do a reboot on the laptop it boots properly and all graphics look normal. To me it seems like the computer is still trying to use the resolution from the external monitors on the laptop screen but I have no idea. Is there anyway to “reset” just the graphics settings to the normal laptop mode without rebooting the entire computer? Does anyone else have this issue?

Thanks, Ben

Hi Ben,

Thanks for contacting us. I’d be happy to help with your docking station!

Based on your description, it sounds like when you disconnect from the dock Windows is having trouble scaling the content on your internal display properly after the external displays are no longer available. As you are using a Dell Precision workstation class laptop that I am betting has a very high resolution (or Hi-DPI) internal display along with external displays that are of a lower resolution this can happen sometimes even when not using or products. I wrote a little about scaling behavior here –>…

A common workaround to subvert this behavior would be to set the resolution of the internal display of your Dell to match that of one or both of your external monitors connected to the dock (following Option Two in this guide –>…), and have Windows set the display scaling to 100% (following part 4 of this guide –>…). This should prevent Windows from scaling the content on all the displays both when you connect and disconnect from the dock.

Can you try that to see if it helps?

Thank you,

Plugable Technologies

This fixed it! Thank you. I did have the displays at the same resolution but I had the internal laptop screen set to 125% scaling. When I brought that down to 100% the issue went away. Thanks again!

Hi Ben,

Thanks for getting back with the update. Display scaling can be tricky to pin down, I’m glad changing the settings as described helped.

Please let us know if you need any help in the future!