"Grand pause" over Remote Desktop - especially screen share apps

Hello. Recently purchased UD-6950H; using with the following config:

  • HP ENVY x360 Convertible 13-y0XX running Windows 10 connected via USB 3.1 Gen 1 port Type A to dock
  • 2 external ASUS 1920x1080 60hz monitors connected via HDMI to dock
  • laptop keyboard
  • Logitech MX Anywhere 2 bluetooth mouse connected to laptop
  • as needed, Plantronics PLT Legend bluetooth headset connected to laptop

Experiencing intermittent lag, especially troublesome over Remote Desktop connection to work. Varies from brief lag to 20+ second “pause” - leaving me to wonder if I’ve lost my connection. (I haven’t.) Closing my RDC and reopening might help- temporarily. Problem is even worse when using webex/zoom/screen share over RDC - to the point of not being able to do my job.

I was not having these types of issues prior to using the docking station - either just on my laptop or sometimes connected to one external monitor via on-board hdmi.

I hope you can help!!

Hello!

Thanks for joining our forums and reaching out about this issue.

To start with, since you mention that you’re seeing an issue when using Zoom, please try disabling the hardware acceleration in the Zoom settings since this can sometimes help with issues with using Zoom with DisplayLink.

Also, I’ll ask you to try the following steps to reset the dock and the software it uses to see if that helps the issue.

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step

  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 9.2 M3 DisplayLink software, found here --> https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+9.2+M3.exe

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

Please let us know whether these steps help or not and I can follow up with next steps if you’re still seeing issues.

Thanks!
-Andrew
Plugable Technologies

Thank you for responding so quickly. I have tried all of your suggestions to no avail. I am only having these serious issues while using Remote Desktop Connection to work. I forgot to mention in my original post that I also experience some hefty lag just picking up a window and sliding it from one monitor to the other (over RDC).

  • Could RDC settings contribute?
  • Frame rate issues?
  • Monitor refresh rate?
  • Does it matter in what order I attach and/or turn on monitors, dock and laptop?
    Grasping at straws. Thanks!!!

Thanks for trying those steps and updating us! There could be an issue with your docking station so I’ll follow up with you by email to get further information and ask for PlugDebug logs to see if we can find the issue here.

We’ll update this thread when we have more information to share.

Thanks!
-Andrew