Gigabit USB 2.0 Ethernet Adapter, Windows shows internet connection, browsers, emails, other applications don't


#1

I’m having a problem with internet connectivity using the USB 2.0 Gigabit Ethernet Adapter. Windows 7 Network and Sharing center reports internet access, but none of my browsers or email programs can access web servers - everything just times out. I haven’t been able to troubleshoot it using Windows 7 because it keeps reporting no problems, so I’ve been trying the usual things with USB and ethernet cables, swapping ports on the router, etc. I have other PCs and media devices connected to the same router, both wired and wireless, and none of those devices report problems with internet access (or I wouldn’t be posting this message on another PC). The latest version of the drivers I have installed is AX88772A. Any ideas on how I should proceed?

Specs
OS: Windows 7 Home Premium
PC: Dell Dimension 8300 3.2 GHz 4GB RAM 1TB free HDD space
Plugable Device: Gigabit USB 2.0 Ethernet Adapter
Plugable Driver: AX88772A
Other Ethernet: all disabled on this PC (lightning strike took out wireless adapter and on-board Intel Ethernet, hence why I used the Gigabit adapter. It’s been running OK since last March 2012).
Router: Linksys WRT54GS Wireless-G/Wired (not the same one that took the lightning hit!
Browsers: FireFox 15.0.1, IE 9, Chrome 20-something

FWIW, I had been having numerous application problems caused by the latest version of the Avast Free Antivirus 7, which I have since tanked. The connectivity problem showed up after I uninstalled Avast. I don’t know if that means anything though.

Any ideas on how I should proceed?

Thanks,
Ron Niquette


#2

Hi Ron,

Thanks for contacting us, we’ll be happy to help. Sorry to hear about the issues getting your USB to Ethernet adapter working, and thanks for all the troubleshooting information.

To start, would it be possible to try the adapter on another computer and see if it installs and works properly there? That way, we can focus on the cable or the computer that your are wanting to connect the Ethernet adapter to.

Also, can you say if there are any link or activity lights on the adapter lit up? There will be a link light on when the cable is plugged in. Another light will come on when there is activity. Do you see either of these?

Another thing to try if your activity lights are on but there’s no internet would be to click the start menu and type cmd in the search box and press enter.

When the command window opens, type ping google.com and press enter. What happens? How about if you ping the ip address of your router?

Let me know happens with these steps and we’ll figure out our best next steps.

Thanks,
Jerome.

Plugable Technologies


#3

Hi Jerome,
Unfortunately I’ve now lost ground with this problem to the point where I can’t try any of those suggestions.

I made the mistake of uninstalling the device and drivers and starting over from scratch. Now I can’t even get the drivers to install. The Installation CD setup program returns an “unable to install” error with no other information to tell me what went wrong.

If I try to install the newer drivers I downloaded from your website, I can install the drivers with trouble. But when I plug in the Gigabit adapter and tell the Found New Hardware wizard to find the driver files automatically, it reports that it can’t find a driver for the adapter. Even If I use the Found New Hardware Wizard to browse to the directory where the drivers are installed, Windows still tells me it can’t find drivers for my device. The files themselves are located in the directory all right, including the .sys driver and .inf installation file.

The version of the drivers that won’t install from the CD is AX88178. The downloaded version of the drivers that’s not recognized by Windows 7 is AX88772A.

So much for starting from scratch. At the moment I’m not willing to install this device or its drivers on this PC because I don’t want to screw up this machine too. I need at least one PC with a working internet connection.

This has been extremely frustrating, constantly getting further and further into the hole with this problem. I’m going to go offline for a bit to reboot attitude before I start all over from scratch again. I’ll report on my progress when that happens.

A parting thought - is it possible that one of those Windows 7 automatic updates killed your drivers? I know there was one yesterday, but with the problems caused by Avast running interference, it was hard to tell what was causing what problem Now Avast has been uninstalled, so something else is going on.

RE pinging Google: I didn’t get back to the point where I could try that, but remember that the Windows network connection and sharing center kept telling me I had a working internet connection. It was my browser, email, and other application software that said there were no connections. I know that IPCONFIG/ALL showed an IP and DNS addresses, so I had enough connectivity to get that far. Applications were the problem, and now the driver software that either won’t install or won’t be recognized by Windows 7.


#4

Hi Ron,

Thanks for all the detail, sorry for all the frustration. It really sounds like something is misconfigured on your system and considering the issues you’d reported with Avast, and also the nature of your problem with applications being block from the internet I think this is the best place to start.

Try booting into safe mode (hold f8 while booting) and completely uninstall Avast. Then when you reboot try running the installer again. We haven’t had any reports of Windows updates breaking our Ethernet drivers, so you should be able to get the install to run completely.

Do you remember the IP address that was assigned before? If it starts with 169., it’s a self assigned address and isn’t valid and means your machine hasn’t been assigned an address through DHCP.

If you still can’t get the installer to run and have uninstalled Avast, send your setupapi.log file to us at support@plugable.com. The setupapi.log file should be located in c:/windows/inf

This file has lots of troubleshooting information for device to driver matching and installation and will help us figure out what’s blocking the install of your USB to Ethernet adapter.

Thanks for your patience while we get this figured out.

Jerome.

Plugable Technologies


#5

Hi Jerome,
I had previously uninstalled Avast using the Revo Uninstaller in Advanced mode, and was able to blow away all folders and registry keys associated with Avast in the process. Booting in Safe Mode won’t do much for me now, since Avast will not appear in any installed programs list or anywhere on the hard drive.

I just tried installing from the CD again per the instructions in the manual, and finally got some kind of error message besides “Install failure”. This is the message I got when I browsed to the location on the CD that includes the driver and INF files:

“ASIX AX88178 USB 2.0 to Gigabit Ethernet Adapter
There is no driver selected for the device set or element”

That still doesn’t make much sense to me beyond suggesting that something is wrong in the INF file.

So I just downloaded the same version of the drivers and setup program from the ASIX website and transferred them to the affected PC via burned CD. I noticed that when I ran the installation setup program, the driver file was not copied to the Windows\System32\Drivers directory. Also, a folder for the driver files was not created in the Windows\System32\DriverStore\Filerepository folder. No error message was displayed during the installation, but the absence of the driver file and folder from those Windows folders is certainly one reason why the installation isn’t working.

I tried setting compatibility modes to “Run as Administrator” for all the EXEs in the downloaded driver folder, but this had no effect. Even though the installation runs without error messages, driver files and folders are not copied to the Windows\System32 subfolders. I’m going to try debugging the problem from that angle for the time being.


#6

Hi Jerome,
I finally got the drivers re-installed. Per my last message, the installation program was not copying the driver files to the Windows\System32\Drivers and DriverStore folders.

I opened the setupapi.log file and saw the clues in there. According to the log, the files were not being copied because the driverstore “already exists” - even though it didn’t.

I searched the registry to see if that was the problem, i.e. that the folderstore path was still in there even though the folder didn’t exist, but I found nothing. I ran the Tweaknow Registry cleaner and tried to reinstall the drivers - but once again, the copy operation failed and the setupapi.log file said no copy was performed because the folder already existed.

So I copied the driverstore folder name from the log file, gave myself permission to create the folder in the driverstore folder, and hand-copied the files from the downloaded installation folder. I then plugged in the Gigabit adapter, and Windows 7 automatically installed the driver without errors, the way it’s supposed to.

My guess is that when I uninstalled the drivers using the Revo Uninstaller, the driverstore folder got deleted but Windows somehow retained a record somewhere that it still existed.

Great. So now I’m back to the original problem. Windows Network reports that I have internet access, but no application that uses the internet can access it. Finally I’m able to try the ping test at least, and sure enough, it fails. All ping requests for various web servers I’ve tried are timing out.

Ive now ruled out IP address conflicts on my LAN, DNS server conflicts with the router, DHCP settings problems. The PC obtains an IP address from the DHCP server, but cannot connect to the router. Go figure. I don’t understand that at all. If the PC can obtain an IP address from the router’s DHCP server, why can’t it connect to the router’s web server?

I’ll have to break for the night and resume the operation tomorrow. Maybe after a complete system restart…

Thanks for hanging in there with me,
Ron Niquette


#7

Hi Ron,

I was just going to send you this link that I found:
http://www.avast.com/uninstall-utility

We’ve seen instances in the past where an Anti-Virus product couldn’t be uninstalled and the vendor provided an uninstall utility that was necessary to get the anti-virus completely uninstall and deactivated. It seems like you are past this part now, but I thought I’d forward it over anyhow.

I’m glad to hear that you were able to get the drivers re-installed and are now back to the original problem. The first thing to try is rebooting the router. The reason is that routers sometimes get into a state where the will give an address to a new device but not let it through to the internet – so reboot / power cycle the router to be sure the MAC table is clear.

Then give it another try, if you are still locked out. Check that Windows Firewall is disabled and try to ping other machines on your network. Make sure you can also ping your machine back from the others.

If your Firewall is disabled, and you still can’t communicate take a look at this kb article from Microsoft. It’s explains how to reset the TCP/IP stack and includes a Fix It button and instructions to do it manually if you prefer.

If you still haven’t gotten any results, I’d start to look at system restore back to a last know good.

Let me know how it goes.

Thanks for your patience,
Jerome.

Plugable Technologies


#8

Hi Jerome,
I’ll certainly give that a try. What really bugs me about this is that it acts exactly the way it would if a Firewall were blocking access to the internet. But I don’t have a firewall running, not Windows Firewall, not Comodo (which I used to have), nothing. I even made sure the Windows Defender and any other malware blockers were out of commission.

Note: either you forgot to post the link to the Microsoft KB article, or encroaching senility is making it harder for me to see things right in front of my face. There’s a ton of evidence for the latter in this thread, so could you post that KB link (again?),

I did a router reset/reboot last night, renewed the DHCP server, and did all kinds of Linksys-recommended things that didn’t work. However, I’ll be repeating the process every time something else changes.

It now seems that the driver installation issue I was having was something entirely different from the connectivity problem, an error I ran into only because I went to re-install the drivers and was a little heavy-handed when I uninstalled them first. Still, I learned a good trick with viewing that setupapi.log file to see what sort of errors were really happening. Otherwise I never would have known that Windows thought the driverstore folder was there, even though it wasn’t.

As far as I’m concerned, you’ve already earned your pay by pointing me to that log.
BTW in Windows 7 there are actually 3 logs in that Windows\INF folder:

setupapi.app.log (for applications)
setupapi.dev.log (for devices)
setup.offline.log (probably a remnant of Windows XP SP3 based on the date-time stamps, nothing interesting in it).

No bother, as long as you remember to check all of them just in case, especially if a device comes bundled with both drivers and applications.

I have to do some normal life things before I give that Avast utility a try, along with everything else. I’m also going to see if there’s an issue uninstalling Comodo, and if there’s a utility to do a “clean” uninstall.

Thanks again and I’ll keep you posted,
Ron Niquette

PS: what’s really a p**ser about all this is that now that I have the drivers installed, I can see that PC on my LAN and transfer files all over the house to and from. I just can’t get to the internet from that PC. It HAS to be a firewall but there isn’t one that I can see…


#9

Hi Ron,

Here’s the invisible link…

http://support.microsoft.com/kb/299357

Sorry I did forget to paste that in my earlier reply. Between that and the Avast utility about the only thing left I can think of is to try MAC address assignment. Here’s a link with instructions on how to do it:

http://www.sevenforums.com/network-sh…

You can temporarily try a MAC on your network that you know is working and see if your machine can get out to the internet with it. Be sure to turn off the other device so there’s no conflict. Then you’ll need to change it to one that’s not in use and see if it still works.

FWIW – I’ve seen a handful of machines where the Windows network stack became so messed up that only a re-install of Windows could get them working again.

It all depends on how painful it would be to re-install and restore your data and applications versus how fun it may be to continue and what kind of time you are willing to invest – and still possibly end up at a re-install.

Keep me posted, you are one tenacious troubleshooter! We’ll help however we can.

Thanks,
Jerome.


#10

Hi Jerome,
I’m back online and all appears to be well! It was probably the Avast uninstall utility that turned the corner for me, though at the same time I did a little searching and found that Comodo Internet Security was still running a service even though I had uninstalled the free firewall. I killed the service and manually deleted the executable, which was in the Windows\System32 directory.

I also noticed that Windows Firewall and Windows Defender services were still running after I disabled them in the Control Panel. I killed those services as well.

The problem with services like that is that they don’t show up in the task manager. In the case of Windows Firewall and Windows Defender services, there’s no way to know what they’re doing, if anything, after they’ve been disabled in Control Panel.

Anyway, after doing all that, I once again have internet connectivity, fast as it’s ever been.

Thanks for the link to the Avast uninstaller! I think that was the major fix.

Have a good one,
Ron Niquette


#11

Hey Ron,

That’s great to hear! I’m glad that we finally found the magic bullet. Thanks for all the troubleshooting and for posting such detailed information back here. It really helps others who may be in a similar state in the future.

Enjoy!
Jerome.

Plugable Technologies


#12

Hi Jerome,

Well, I certainly hope someone can use it. There was a lot of interference from non-related issues on my system, but the bottom line for anyone reading this is that the Avast uninstall utility most likely fixed the connectivity part of the problem.

Everything else was “collateral damage”. I think you made a good point about re-installing windows. I may or may not need to do something about that Windows Network Stack, but certainly this system has gone too long without a major restart. All of the other symptoms I was battling were the result of that, I think.

No doubt about it - when defragmenting the hard drive (optimized to move the EXE files to the “head start”) doesn’t improve performance, it’s definitely time to start making major backups and gathering all the Windows 7 install discs and upgrade files to prepare for the PC equivalent of major endoscopy work. In other words, “a good reaming”.

Moley, what a journey that turned out to be, eh? I can think of better ways to spend a holiday weekend. I hope you were able to get some time off, at least. I sure didn’t. I’m still recovering from the time lost on everything I have to do around here.

Thanks once again for all your help.

Have a good one,
Ron Niquette


#13

Hi Ron,

Ever since Microsoft Security Essentials came out, I’ve used all of the third party AV solutions less and less. I haven’t yet (knock on wood) had a similar issue with Security Essentials, but we’ve seen quirky - troublesome behavior with many of the others. I’m glad you recovered your machine – you have many more options on doing backups (hint, hint) when your machine is connected. If you keep a good backup set, you can re-image the machine with little effort lost. Some fun tools in this area are Macrium reflect and Windows Sync Toy. Both are free, Macrium Reflect can image your entire drive to a network share once your Windows installation is complete, updated and configured and then boot from a CD and restore from the same network share. Sync toy can be setup to sync certain folders at predetermined increments.

http://www.macrium.com/reflectfree.aspx
http://www.microsoft.com/en-us/downlo…

Just thought I’d pass those along in case you’re interested.

Thanks again,
Jerome.


#14

Hi Jerome,
Thanks for the additional pointers. Yes, I have a copy of SyncToy and still use it from time to time. My main backup tools are good old WinRAR and XXcopy, a freeware program the extends Xcopy with all sorts of useful backup options.

The reason I don’t use those online backup services is that I’m heavily into DVD and Blu-Ray authoring. You know what that means in terms of hard drive usage and the size of any backups you make.

Even the cheaper online backup services would cost me an arm and a leg because of how much storage I need, so I instead I use a pile of external USB hard drives that I cycle back and forth between here and a safety deposit box (I actually asked the bank manager if the vault was rad-hardened! It was funny. The look he gave me… I said, “Just joking, don’t worry, I won’t be storing Plutonium in your vault. No, seriously. Trust me.”)

For the rest of the stuff like documents, programs, etc, I use WinRAR to archive the files to USB memory sticks which I carry on my keychain. I have two 32 GB sticks which are enough for the vital non-video stuff.

That takes care of backups at any rate. Disk imagers I haven’t explored much because I do these system restarts on such an infrequent basis. When I’ve had to restore a system, I’ve always re-installed the OS on a formatted drive, then recovered individual files from backup (also, I got burned pretty bad with Acronis Disk Image, so I’ve been a little gun-shy of the commercial products that do image backups)

There’s always the Windows backup./restore utility which I have used successfully in the past to resurrect my dad’s laptop.

However I’ll certainly check out those links. This isn’t lip service, but based on everything that’s happened so far, I think you’re one of the few guys in The Shallows who knows what the hell is going on when it comes to basic survival skills.

Final note: I’ve been slow to tank the third party AV programs and take on Windows Security essentials because my experience with their Firewall is that it’s difficult to configure and monitor. That’s an unscientific bias that I should set aside to give Essentials a try, especially in light of the way Avast practically wrecked my system. What a disaster that was! Never again will I risk using Avast. At the moment I’ve replaced it with AVG which is stable (so far) but slow. I’m not happy having it there, that’s for sure.

Now to those links…

Thanks again,
Ron Niquette


#15

Thanks again Ron for sharing all the troubleshooting detail on the forum. Let us know if there’s anything else we can do.

Jerome.


#16