Getting my USB-BT4LE dongle to work in Ubuntu 12.10 Quantal


#1

The dongle shows up in BlueWho as a local adapter, and it even finds the Bluetooth keyboard. But it doesn’t seem to want to work, tried 3 different bluetooth devices with no success. Here are relevant info:

Output from dmesg (cleaned up)
Product: BCM20702A0
Manufacturer: Broadcom Corp
Bluetooth: can’t load firmware, may not work correctly

Any suggestions? My kernal is LINUX 3.5.0-42 i686 and the distro is Ubuntu Quantal 12.10.

EDIT: Just to clarify - I know the rest of the bluetooth stack is working, since I plugged in a Microsoft touch mouse dongle and the mouse worked flawlessly.


#2

Hi Matt,

Thank you for posting your question about the Bluetooth dongle. I will do my best to help you.

The Microsoft touch mouse doesn’t use Bluetooth (it has a proprietary radio), and that is both good and bad news. Good because different adapters can interfere with each other, bad because the fact the mouse works doesn’t really tell us anything about whether Bluetooth is operating.

First of all, can you tell me what, if any, Bluetooth packages you have installed?

Second, could you run these commands for me at the terminal with the adapter plugged in, and send me the file called “41363.txt” to support@plugable.com. Please put "for ticket 41363 in the subject line.

dmesg > 41363.txt
lsusb -v >> 41363.txt

Thank you,

David
Plugable Support


#3

Thanks for the Reply David. I take your meaning on the Touch mouse.

I guess the other piece worth mentioning would be that when I plug your dongle into my windows 8 box, it works with the USB keyboard i have no problems. So we can almost certainly eliminate hardware as an issue.

In any case, I have sent you the txt file per your instructions.
As far as the bluetooth packages…
bluetooth (4.101-0ubuntu6)
bluez (4.101-0ubuntu6)
bluez-alsa (4.101-0ubuntu6)
bluez-cups (4.101-0ubuntu6)
bluez-gstreamer (4.101-0ubuntu6)
bluez-tools (0.1.38+git662e-3)


#4

Hi Matt,

Thanks for the information. I’m not seeing the txt file as having come in yet.

Can you also tell me what devices you are trying to connect?

Thanks!
David


#5