Gaming Laptop Not Reacting to TBT3 Dock

When I connect the TBT3 dock to my gaming laptop (which worked perfectly with a USB-C plugable dock), it makes the new device connected chime, but does nothing else. Monitors don’t come on, external devices don’t connect, etc.

Any suggestions for how to troubleshoot this?

Some additional details, as I educate myself on TBT3. When I run the Thunderbolt software and plug in the TBT3-UDZ, it does not recognize it as a Thunderbolt device and does not appear in the list. It is probable that I have never plugged a Thunderbolt device into this laptop, as nothing appears in the software, not even the Port name. In the Bios, I can choose between Legacy, Unique ID, One Time Key (or something like that), or DP. I have tried all of the first three, with no luck. The bios is old, so I have asked the manufacturer if there could be an update, but have not heard back yet.

Bottom line, the computer is not able to tell that this device is a TBT3 device, and I can’t figure out why or what I might do to remedy the issue.