fstrim not working on ssd in usb 3.0 docking station


#1

Hi,

I’m using the usb 3.0 to sata docking station - the kind that lays flat - with a Samsung 850 EVO 250GB ssd. I’m using it with a linux OS - Ubuntu Server 14.0.4.

Basically the fstrim command won’t work through the interface, so I have no way to trim the drive periodically. Also, the disk tools won’t work through the interface either - smartctl reports: unsupported usb bridge.

I saw a report that another brand of usb to stat adapter was working with a firmware update. Oddly the update they referred to was a plugable firmware, but on a different brand of hardware. smartmontools reported that firmware version 2580 worked. But I couldn’t find that listed on the plugable web site anywhere.

I tried downloading the firmware update tool but couldn’t figure out what firmware I had. I didn’t want to update unless the firmware was actually newer than I already had. I just bought the unit on Amazon 2 days ago. model = USB3-SATA0UASP1. Serial number = 1094002328895.

Anyone know of a solution? Running trim periodically is pretty important.

Thanks


#2

Hi Mike,

Thanks for posting.

With the enclosure being so new, it will be on the new firmware and shouldn’t be in need of an update.

As far as the tools go, we’ve successfully tested smartctl with this dock previously. Syntax should be: sudo smartctl -d sat,16 /dev/sdx -t [test_type_argument]

(The -d sat,16 is key for passing the ATA commands correctly through the USB bridge, so guessing that’s why it didn’t work previously.)

Regarding fstrim, I’ll setup some lab time later today to test and see what we can find.

Thanks!
Gary


#3

Hi Mike,

Tested a bit with fstrim and am getting an “ioctl failed” error when doing so. Doing a bit of research, there are people reporting that a Linux bug is preventing TRIM from functioning on USB attached SSDs.

The bug report states that “TRIM is still (currently) not possible for unknown reason, might be the usb-storage kernel module issue I guess.” - so it seems like it’s on their radar but this but unresolved for the time being.

Thanks,
Gary

Ref:
http://askubuntu.com/questions/262154…

https://bugs.launchpad.net/ubuntu/+so…


#4

Thank you very much. I now can run smartctl.

I’ll follow up on the linux thread to see if a resolve can be found. I’ll post here if/when something is worked out.


#5

Glad to hear smartctl is now working as it should!

Look forward to any progress updates regarding the TRIM issues if a fix is found.

Thanks!
Gary


#6