File Explorer not working correctly when connected to docking station


#1

When connecting my Dell XPS 13 9360 to my Plugable USB-C docking station, file explorer won’t show changes to files (name changes, new folders, deleting folders) unless I go back a level and then go back into the folder. Then the changes made are shown. Similarly, it won’t show the icons for files saved to desktop unless I refresh the desktop.

When disconnected from docking station, everything works normally. This is a recent problem. Worked fine last time home about 2 weeks ago.

Downloaded all the most recent drivers for computer, windows and docking station and no luck. Any suggestions?


#2

Hi David,

Thank you so much for reaching out to us, I am sorry to hear that you are running into this issue, but I would be happy to assist!

Just to make sure I have all of the right information, when you have a moment, could you please visit www.plugable.com/support/plugdebug and download and run our PlugDebug application? Once it completes, it should then save a .zip file to your desktop. Please attach that .zip file to a direct email, and send it to our support email address at support@plugable.com, with “Ticket No. 199972” in the subject line. I just want to review some of the log files to see if anything points in a specific direction, as this is a very strange issue and is normally not directly connected to our docking stations.

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3