External monitor stuck to low def

Hi there,

Last friday after replugging my laptop on my docking station my second external display got stuck on a VGA-like resolution, while my other one is 1080p… It worked well before but now it’s looking kind of ridiculous really and what’s annoying is that I can’t use that display anymore because of this
I’ve attached some pictures of my setup so you can see how it looks. I tried to use another monitor without luck and I’ve noticed mac os doesn’t recognize the monitor (says “no monitor”, see attached pic).

Cheers

My configuration

  • 15" macbook pro 2018
  • USB-C 4K dock
  • 2 external displays (1 hdmi, 1 displayport)

Hello Terence,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

If you haven’t already done so, fully unplug the dock from all devices, power, and USB-C cable to the host computer. Wait about 30-60 seconds, then reconnect the power cable first, USB-C host cable next, and USB devices last. Sometimes a reset in this order can resolve this issue.

If that doesn’t help, what version of macOS are you using? (sorry I can’t tell in the picture if it’s Mojave or Catalina)

We can try a driver reinstall by uninstalling the existing version and then reinstalling the latest, then taking care to ensure the macOS Gatekeeper security settings allow the drivers to run. We have instructions here:

https://plugable.com/drivers/displaylink/mac/

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/

Hi Joshua,

Thank you for your pointers but unfortunately the issue is still there…
Sorry I forgot to mention my macos version which is Mojave (10.14.6)
What I tried so far:

  • switching monitors
  • switching cables
  • resetting the dock following your instructions
  • uninstalling/reinstalling the displaylink driver (I used version 5.2 which is the latest)
  • deleting macos’ display settings’ plist file as per the stackoverflow answer found here
  • deleted other plist files as per that answer
  • ran the displaylink “reset macos display persistance” found here

I noticed that the display settings window says “no monitor” on the falty one, which leads me to think it’s not detected well but it’s only a wild guess…

Cheers

Terence

Thanks for this additional information. Also for letting me know everything you’ve tried. I think that based on the behavior and all of the troubleshooting tried that we’re probably going to want to replace this dock under warranty for you. I suspect that the DisplayLink chipset within the dock that controls the two DP ports may be failing.

To send you a pretested replacement under warranty I’d just need to get some information from you about the purchase, etc. I will contact you directly via email for this information.

Thanks!
Josh