External monitor not detected when using DVI to HDMI cable

Hi,

I just bought the docking station Plugable USD 3.0. I have a Dell Laptop windows 10, a Dell monitor with DVI ports in the back. If i use the cable directly from the DVI monitor to the HDMI port of the laptop i can see same screen on both the monitor and the laptop. But if i connect with the HDMI port of the docking station the monitor remains black. I followed the instructions of an older post from 2017 for somebody who had same problem. It didn’t work even if i installed, uninstalled, reboot, install reboot and connect. Same thing if i use a VDI to VDI cable which i know is working correctly.

Thanks,
Monica

Hi Monica,

Thanks for joining our forums, we’re happy to help.

Since you’ve already tried to uninstall and reinstall the DisplayLink software on your computer and that didn’t fix the issue, I’ll ask you to run our PlugDebug troubleshooting tool and send us the logs. Please do not post the logs here and instead email the logs to our support address directly at support@plugable.com . Please mention ticket #296419 in your email and we’ll connect the two threads to help you with this issue.

Please plug the device into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please let us know if you have any questions about this or any trouble running our PlugDebug tool and we’ll be happy to help.

Thanks!

-Andrew T.

Plugable Technologies

Hi Monica,

Thanks for working with us on this issue and I just wanted to update the forum thread here with the outcome of the issue.

After reviewing the troubleshooting logs we found that the dock was not working correctly and sent a replacement for this docking station and the replacement appears to be working correctly.

Please do reach out to us again if you see any other issues or if there’s anything else we can help with.

Thanks!
-Andrew T.
Plugable Technologies