External Monitor Blank in "On 2" Only Mode, But Works in "Duplicate" Mirror Mode.


#1

I just purchased the USB 2.0 Universal Docking Station and have set it up. What I’ve tested so far works like a charm. When in Duplicate mode for the monitor, I get what I expect on both the monitor and the laptop screen.

However, if I switch to “show desktop only on 2” mode, which should display only on the monitor and leave the desktop blank, it gives me a blank on both locations.

I’ve checked the drivers for DisplayLink (via the menu from the Pluggable app icon on the TaskBar/Action Center), but I am current. I also walked through the pdf manual, but I am scratching my head on this one.

Is there some configuration change I am missing?

I am using a Lenovo Thinkpad E420. My monitor is a Dell 2408 WFP.


#2

Hi RD,

Thanks for posting here, we’ll be happy to help. If you use the DisplayLink User Interface to set the external display to monitor and turn notebook screen off does it still behave the same?

To do this click on the blue square icon in the lower right hand corner of the screen. You’ll see a menu entry for your docking station. The options to set as main monitor and turn of notebook display are here.

Does that help?

Let me know what you find!

Thanks,
Jerome

Plugable Technologies


#3

I was about to post the very same information you are asking about as a follow up entry.

Yes, that “blue square icon” that looks like a monitor is the “Plugable app icon” I was referring to above, correct?

The entry for my docking station is the “DisplayLink Manager” entry I presume, as I don’t see anything specific to the docking station labelled such (and it appears above: Check for Updates, Optimize for Video, Fit to TV, Advanced Configuration). In fact, this and the “Advanced Configuration” entries bring up the Win 7>Appearance and Personalization>Display>Screen Resolution screen that I can also access via Control Panel.

Assuming I am correct, and understand your instructions, I have already tried, and, as mentioned above, was about to report here…

When I switch to have it “show desktop only on 2” (the Dell monitor is defaulted to monitor #2), I get blank screens on both laptop (expected) and monitor (whoops!).

Of note, I’ve been reading on the net that one possible workaround is changing which monitor is primary. However, after changing from “duplicate these displays” to “show desktop only on 1” (my laptop screen), and then clicking on the monitor #2 graphic in the upper portion of the popup, the little check-box to “make this my main display” option is greyed out.

I’ve also tried the Function key that is design for quickly changing between modes when connecting to a projector (normally via the VGA port), but no setting there resolves this problem. I suspect it is just a fast-path interface to execute the same commands that the “DisplayLink Manager” path above does.

Looks like my laptop does not completely recognize that there is a separate monitor at the other end of the usb cable. It seems to just want to “split the signal” going to the laptop screen and send it thru the usb, but that is it.


#4

I saw that there was a way to collect some info via a logging tool for DisplayLink. Would that help?


#5

Also want to say that I’ve tried it all on two of my three usb ports from the laptop.


#6

Hi RD,

Thanks for all the additional detail, here’s the link on how to run the DisplayLink Support Tool.

http://plugable.com/support/tools/dis…

Once you’ve run the tool, please forward the resulting .zip file over to us a support@plugable.com along with your Amazon Order Id, and a link to this tread.

Thanks,
Jerome.


#7

Jerome, hello!

Saw your request to try from the Windows Interface / Desktop. You guessed right that I had tried that already, but did so again, just in case.

I am running it in “duplicate these displays” mode, so clicking on the Identify button just shows a big “1 | 2” on the screen. When I change to “show desktop only on 2” (my usb connected monitor) both monitor and laptop are blank. When I change to “show desktop only on 1” only the laptop shows. When I close the laptop lid, while it is in “duplicate” mode, both screens go blank - even though I have power management set to “do nothing” when plugged in.


#8

Hi RD,

As and experiment, let’s try turning off the “duplicate these displays” mode and select “extend these displays” then Identify, then send the display only to which ever one is the external display.

Does it still go blank?

Jerome.


#9

Jerome, hello!

I tried the experiment just now. When I specify the external monitor, only the laptop screen has the desktop displayed. This is true if I apply the “extend” mode to either one of the monitors, actually - it does not seem to matter which I pick.


#10

Just to clarify, I meant, either one of the monitors to be the external monitor or the laptop screen.


#11

Hi RD,

Thanks for taking those steps. It’s sounds like your setup is working hardware-wise now we’ll just need to figure out a configuration that works for what you are wanting to do.

It sounds like there’s two issues, one is that the screen is going blank when you close the screen even though you’ve set the power management behavior to “do nothing”. Let’s work on this one second. Once we get the display setup correctly, we’ll see about the power management properties.

I’d like to have you update to the 6.3M1 driver package from DisplayLink, here’s the link:

http://displaylink.com/support/sla.ph…

With this driver version, you’ll find a couple of differences in the menu available from the DisplayLink User Interface Icon. Once it’s installed, try using the settings available in the menu for the UD-160-A. You should be able to choose “Set as main monitor” and “notebook monitor off”.

Let me know if that helps.

Thanks,
Jerome.


#12

Jerome, thanks!!!

That seemed to do the trick. I’ve just loaded and tried it now and not run through all the options, but it seems to do the one screen only … with laptop lid open…will try out some other scenarios and report back.


#13

Jerome, hello again.

Just thought I’d report that closing the laptop lid with “show desktop only on 2” works just fine. I tried extending the screen with laptop=desktop 1 and dell monitor=desktop 2. This works, but with something a little unexpected…

The mouse reaches the Dell from end to end of the monitor (i.e. it can touch any part of the screen real estate), however the background image is dead center and black around the four sides of it. I’ve been using the default Lenovo background on the computer since new (lame, I know ). Is this just a characteristic (dimension in pixels) of the image they used for the background? I suspect so, but just want to validate.

Otherwise, everything is as expected. Great support for this product, and is a significant part of why I purchased it. Thanks for your help!


#14

Hi RD,

Thanks for the updates. I’m glad to hear the driver update did the trick. As far as the desktop image, you should be able to just right click on the background, choose personalize, then desktop background, and then under Picture Postion choose “fill”.

That should resize the image to fit you background.

Let me know if there’s anything else I can help with.

Thanks again!
Jerome


#15