External display not working Plugable UD-3000 using DVi-D ans Surface 3.0


#1

Have Surface 3 attached to the pluggable with external; display connected and a third display connected directly to Surface. Today hooked up Surface to pluggable and the third display. Display not working from the pluggable. Connected the laptop only to the pluggable - no display… Cycled power on and off to monitor, pluggable and laptop no impact. Confirmed monitor working. Used different laptiop with pluggable and it worked. Therefore the difference is the Surface with the Pluggable.
What now?


#2

Hi Wayne,

Thanks for reaching out to us, I’d be more than happy to assist you with your Plugable UD-3000.

First, can you please reinstall the DisplayLink drivers, this will verify whether those drivers are working properly. Please do so by following these steps:

  1. Disconnect the adapter from the computer.

  2. Run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  3. Download driver v7.6 M2 from the below link and follow the installation prompts.
    http://www.displaylink.com/support/sl…

  4. Reboot the computer.

  5. Replug the adapter to the computer. Allow several minutes for the driver to enumerate and for the firmware upgrade to complete.

After that is done, if the problem still persists, it would be helpful to get the logs produced by our tool Plugdebug. Simply go to this site, follow the prompts there, and send the resulting .zip file to support@plugable.com.
www.plugable.com/plugdebug

Regards,

Stephen
Plugable Technologies


#3