Every 30 seconds my monitor shuts off for 5-8 seconds then comes back on when my laptop is closed


#1

dell xps 15 laptop - 4k display
dell 2001 fp monitor - 1600x1200 display
plugable usb-c triple display docking station ud-ultcdl - attached to laptop with included usbc/thunderbolt cable
monitor is attached to docking station with dvi cable
windows 10 home

Whenever the laptop is closed, about every 30 seconds the monitor shuts off, the computer makes a beeping sound, then another and the monitor comes back on.

Yes, I have rebooted my computer, updated the drivers, installed the plugable drivers and run windows update. I have searched the internet already. The cables are tight. I don’t have another monitor to test with.

monitor works fine with the laptop is open.
I have set the power settings for when the laptop closes to “do nothing” (see included picture)
I set the display to secondary only and that does not help.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1478355/powersettings-picuture_inline.png?1472944079)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1478355/powersettings-picuture.png?1472944079)


#2

Hello Jennifer,

If you haven’t done so already please read this important blog post about Dell XPS systems and our USB-C docks:
http://plugable.com/2016/06/30/invest…

Here are the recommended steps to resolve this issue. Please double check and make sure you have installed the following updates, some were updated quite recently:

  1. Latest BIOS: http://www.dell.com/support/home/us/e…

  2. Latest Thunderbolt 3 NVM firmware: http://www.dell.com/support/home/us/e…

  3. Latest Thunderbolt 3 drivers: http://www.dell.com/support/home/us/e…

  4. Latest graphics drivers:

http://www.dell.com/support/home/us/e…

AND (if your system has NVIDIA graphics)

http://www.dell.com/support/home/us/e…

If that alone does not help there may be another option we can try. We’ve had reports of some customers disabling WiFi via Airplane Mode or turning down the WiFi transmit power to 75% in the Device Manager settings to keep WiFi while having the dock attached.

  1. To do so navigate to the Device Manager.
  2. Then go to “Network adapters”.
  3. Expand it and then find your wireless card.
  4. Then right click and go to “Properties”.
  5. Click on “Advanced” and scroll through the list under “Property:” and find “Power Output”.
  6. Select it and to the right you will see a drop down menu “Value:” for the power.
  7. Drop the power to 75% and click OK. I then suggest rebooting the computer.

If your wireless card doesn’t have these options then Airplane Mode is the best alternative (some Dell systems may have an Intel WiFi installed instead of the basic Broadcom and these functions are not available).

Also if your wireless router supports it switch to using a 5GHz WiFi band vs the standard 2.4Ghz band and that will help as well. (If you need to use WiFi)

You can also try moving the dock further away physically from your laptop and/or not running the laptop with the lid closed.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Plugable Technologies


#3

Thanks for the reply. I already had the drivers installed and updated. I lowered the wifi power to 75%, and it appears to be working now! YAY. I will have to give it a longer workout when I have more time, but seems ok so far.

Thanks for the reference to the blog, not sure how I missed that, but I was searching on monitor disconnects, not usb disconnects. Strange how it only happens if the screen is closed, that must have been a pita to debug.

Anyways, thanks for the help, I really appreciate all the details and explanations. I am now a happy camper with my docking station.


#4

Thanks for letting me know that the WiFi setting appears to have helped. If you run into more issues definitely let me know!

Best wishes,
Josh


#5