Ethertnet USB 2.0 Gigabite LAN driver problems


#1

When I install the divers for my USB 2.0 Gigabit Ethernet Adapter 10/100/1000 it says that installation was complete and I then clicked “Finish”. After that nothing happens. I manually reboot the system after waiting for a while but don’t see any entry in the Device Manager under Network. All I see is the old network card that is presently in use. Help!!!
I have a Windows Vista OS on my computer.


#2

Hi Shadeed,

Thanks for posting your question here! If Windows detects the Plugable USB2-E1000 USB 2.0 Gigabit Ethernet LAN Adapter and the drivers for it are installed, you should be seeing it listed under ‘Network adapters’ in Device Manager as shown in the screenshot below:
!](https://d37wxxhohlp07s.cloudfront.net/s3_images/852626/Device%20Manager%20Gigabit_inline.png?1359875146)](https://d37wxxhohlp07s.cloudfront.net/s3_images/852626/Device%20Manager%20Gigabit.png?1359875146)

If the Plugable USB2-E1000 is detected by Windows but the drivers are not installed then the device show up under ‘Other devices’ with a ! in a yellow triangle on it instead of under ‘Network adapters’.

If the device is not listed under ‘Network Adapters’ or ‘Other Devices’ in Device Manager, then it is an indication that the system is not detecting the device at all.

Windows will not detect the Plugable USB2-E1000 if :

  1. The port on which the device is plugged in is faulty or the device is not well connected to the port

  2. The port is not providing the device with 500mA of power to power up

  3. The device is faulty

Unplugging the device and plugging it to another inbuilt USB 2.0 port on the system making sure the device is plugged in completely would help rule out a faulty port or a port not providing 500 mA of power for the unit to power up.

If the unit is not detected when connected through any inbuilt USB 2.0 ports on the system, then it points to a failed unit. If that is the case, please shoot us an email at support@plugable.com with your Amazon Order ID and a link to this thread and we will take care of the issue.

Regards,
Roze


#3