Ethernet stopped working after Big Sur 11.2 beta 2

A few days ago I purchased this Dock and it was working perfectly. Then I installed the Big Sur 11.2 beta 2 update (build 20D5042d). I was running 11.2 Beta 1 before. Now the Ethernet will not acquire a DHCP lease. I’ve tried removing and re-adding the interface from the Network settings in System settings to no avail. It just self-assigns an IP address with no connectivity. FYI, using a M1 13" MacBook Pro.

I suspect this is a Big Sur problem, but I do want plugable and other customers here to know about it and feel free to offer any suggestions.


Update: I tried an Anker USB-C ethernet dongle and it works fine, so… maybe something with the chipset/driver in the Plugable?

Hi Kevin,

Thanks for posting!

We haven’t had a chance to test with Big Sur 11.2 Beta 2, but what you report isn’t expected. If you haven’t tried already, I would recommend performing a power-cycle of the unit to reset its internal hub chipset. We’ve seen that this can often restore the dock back to a working state when one or more of its functions are not quite working. To do this, please follow these steps:

  1. Disconnect all USB peripherals and the Ethernet cable connected to the dock
  2. Disconnect docking station from host machine, then disconnect the power adapter from power
  3. Leave unplugged for 1 minute for power to dissipate
  4. Connect docking station initially into power only
  5. Connect docking station to host machine, then connect USB peripherals and the Ethernet cable test for functionality

Please let me know if this helps at all.



Mitchell’s boss: give Mitchell a raise.

That seems to have cleared it up. Ethernet is working fine now. Thanks for your timely help!

Great! Thanks for the update – I’m glad that restored the Ethernet connection :slight_smile:

I’ll be closing this thread, but for any other questions or issues, please don’t hesitate to open up a new topic or reach out to us directly at We’re glad to assist.

Best wishes,