Ethernet Port Speed Issues

Hi there. I’m having some issues with the speed of the ethernet port on the UD-ULTCDL dock. I have a Gigabit connection. When testing with other wired laptops in the house I typically get a speed of 900-940Mbps. When using the Plugable dock I max out between 550-600Mbps. I’ve tried this on my main laptop (Razer Blade Advanced 2019) as well as with the dock plugged into an HP Z-Book, both have the same results. Both laptops have the latest Chipset and USB-C/Thunderbolt drivers installed and both are running Windows 10 Build 2004. I have the DisplayLink 9.2.2420.0 software/drivers installed.

Any thoughts on this?

Hi Colin,

Thanks for posting!

Given what you’ve reported, I’d like to start by manually setting your Speed & Duplex setting, rather than letting it auto-negotiate the Ethernet connection, as we could be dealing with an issue with the auto-negotiation of the network speed failing. To do so, please follow these steps:

  1. Ensure that your computer is connected to the UD-3900 UD-ULTCDL, then connect the Ethernet cable to the UD-3900 UD-ULTCDL
  2. Navigate to Control Panel > Network and Internet > Network and Sharing Center > Change adapter settings
  3. Right-click on the wired Ethernet connection, then choose Properties
  4. Choose Configure… , then navigate to the Advanced tab
  5. Locate the Speed & Duplex option and select 1 Gbps Full Duplex
  6. Disconnect and reconnect the UD-3900 UD-ULTCDL dock from your system

Does this change make any difference?

Thank you for giving us a chance to help!

Mitchell

EDIT: Fix product model

So just to confirm, it’s a UD-ULTCDL, not the model you mentioned above. I confirmed that it’s already connected to my router via 1Gbps but I made the changes you suggested and I’m still having the same issues. There’s no way it’s a 10/100 vs 1Gbps problem as the speeds are already between 550-600Mbps, much higher than a 100Mbps connection.

Apologies for the incorrect product model, I’ve corrected that in my previous reply.

At this point, I’d like to request some logs from one of Windows laptops to best investigate further. Could you please keep the Plugable UD-ULTCDL dock connected to your system (with the Ethernet cable connected to the dock), then navigate to our PlugDebug tool and follow the instructions there?

Please send this ZIP file to us directly at support@plugable.com and include “Ticket #321526” so that we match up the details to this case accordingly.

Thanks!

Mitchell

So I did some troubleshooting and it seems that if I roll back to DisplayLink Ethernet Driver Version 9.0.1558.0, which is included in the DisplayLink 9.0 M1 package then I get full speed on the ethernet port as expected. If I use the latest package, which is DisplayLink 9.3 M2 (Ethernet Driver Version 9.3.3309.0), I run into the problem of only getting about 550-600Mbps. I was able to reproduce this with two separate PCs so I suggest someone on your side give it a try running Windows 10 Build 2004.

Thanks Colin. Glad to hear you were able to resolve the issue on your end back rolling back to an earlier driver version.

We’re currently investigating this internally to see if we can reproduce the same problem with a host running the 2004 build.

Thanks!

Mitchell

Hi Colin,

We attempted to reproduce your findings in our test labs with a Windows host running the 2004 build, as well as the DisplayLink 9.3 M2 version. We used a UD-ULTDCL docking station of course for the Ethernet connection.

Our local iPerf test resulted speeds over 800Mbps, which is typically what we can expect, and obviously does not match your experience.

There is no obligation to continue troubleshooting here, but if you would like, we would be interested in seeing if you can see the same Ethernet speed limitation with DisplayLink’s newest driver of 10.0 M0:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool (https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 10.0 M0 DisplayLink software (https://www.displaylink.com/downloads/file?id=1649)
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

Once again, if you would rather not spend more time here, please feel free to disregard and we can close this topic.

Thanks!

Mitchell