Ethernet not connecting unless I reboot the docking station

Hi, I’m using a UD-ULTCDL USB Type-C docking station, and recently when I reboot my laptop, ethernet does not connect unless I then reboot the docking station. Ethernet always connected quickly in the past. I switched cables, but got the same result. I also connected the same cables directly to my laptop, and they work, so it looks like it’s not a cable problem, but rather something to do with the docking station ethernet port. I checked drivers and have the latest Display Link, though I suspect that has little to do with Ethernet connection. Any ideas? TIA, Jeremy

Hi Jeremy,

Thanks for reaching out to Plugable support! I’d be happy to help with that docking station.

The Ethernet connection is actually driven via the DisplayLink chip in the UD-ULTCDL dock, so it is a good idea to ensure that the DisplayLink driver is up-to-date.

The first steps we’ll want to take is to make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool (https://www.displaylink.com/downloads/file?d=64)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 10.1 M0 DisplayLink software (https://www.displaylink.com/downloads/windows)
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

If these steps help, great! If not, I’d like to request some logs from your system to investigate further. Could you please keep the Plugable dock connected to your system (with everything still attached), then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there?

Thank you for giving us a chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

Richard,

Thanks very much. Your advice was easy to understand, and seems to have worked, so I’m now happily back to having my laptop connected to all my peripherals by just one USB-C cable. And sorry for the delay in getting back. I forgot to turn on notifications, and temporarily forgot about the issue.

Jeremy,

Thanks for the update and I am so glad this is working.

Have a good rest of the week.

Richard A
Plugable Technologies
https://plugable.com/support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.