Ethernet network NAS connected directly to Plugable UD-3900 shows Network Cable unplugged

I’m currently using a wireless network and a have an Ethernet NAS. I want to connect to the NAS Device by setting a static IP on my Plugable Ethernet Adapter but it shows “Network Cable Unplugged”. I use this NAS once in a while so I have to connect it directly to my laptop and disable the wireless adapter and then it works. Is there any way to connect it to the Plugable and temporarily use it? The NAS for example has a static IP of and I set the pluggable adapter to Thanks!

Hi Tomasz,

Thanks for contacting us, I am sorry this is not working as expected.

Unfortunately, when you have both the Wireless and Ethernet on the same subnet, the operating system may not find the best path to the device. To expand on this, both the wireless and wired networks are using the same addressing space, 192.168.1.*, the computer assumes that anything in this address space is available to both devices, if you are using the Wireless for the Internet connection it will be the primary when the operating system starts to search for the NAS at, not finding the connection.

One option is to reassign the NAS to another address range and assign the Plugable Ethernet port to another address within the same range. If you don’t use the Ethernet port for any other network connections this should be a fine fix.

For instance:

  1. Set the NAS address to
  2. Set the Plugable Ethernet address to
  3. Connect to the NAS using the new IP Address

Please let me know if this works out for you.

Thank you,

Plugable Technologies

Thanks for the reply, but I tried this but it still does not work. I changed the IPs like you mentioned and the Plugable Ethernet still remains as “Network Cable unplugged”. I have manually disabled all of my other network adapters (wireless and Bluetooth) before doing any tests.

NAS address =
Plugable Ethernet address =

I tested directly from my laptop ( to the NAS ( and I am able to access and ping.

I also Tested From my laptop ( to the Plugable Ethernet ( and the plugable ethernet becomes active and pingable and no longer displays as “Network cable unplugged”.

I have a D-Link DNS-321 if this helps. It’s odd becuase it just doesn’t see the cable is plugged in.

Any advice would be appreciated.

Hi Tomasz,

Thanks for giving that a try, even though it says the cable is not connected, are you able to successfully ping the NAS IP address when it is directly connected to the docking station’s Ethernet?

Is it possible to test the docking station’s Ethernet connected to the network ( possibly directly to the router ) to determine if it is functioning correctly? ( testing connecting two interfaces on the same system may not properly test the adapter or port ).

Thank you,

Plugable Technologies

Hi Pat,

I tested the Pluggable port directly to the router and it functions correctly.
I am unable to ping the NAS when it is plugged into the Pluggable ethernet port.

Any other ideas would be appreciated :slight_smile:


Hi Thomaz,

Thanks for getting back to me.

There are a few possibilities which prevent the UD-3900 network port from detecting the connection, one possibility is the Ethernet controller in the docking station is not capable of operating in half duplex mode. We can start by checking if the connection between the NAS and the computer is in full duplex mode. To check if the NAS is operating at full duplex, please perform the following:

  1. Connect the Ethernet patch cable from the NAS to the network port on the computer, modify IP addresses as necessary and verify the device is communicating properly
  2. Open PowerShell in Windows - Right click on the start menu and select “Windows PowerShell (Admin)” from the popup menu
  3. Enter the following command ( without the quotes ): ​"Get-NetAdapter | SELECT name, fullduplex"
    Please copy and paste the output of this command into your response.

Thank you,

Plugable Technologies


Below are the results with the NAS plugged into the computer

name fullduplex

Bluetooth Network Connection True
Ethernet 2 True
Ethernet True
Wi-Fi True

Hi Thomaz,

Thanks for checking the duplex mode.

It appears the NAS is capable of communicating at full duplex, the next thing to try is to force the settings onto the adapter on the docking station to see if it is having a detection problem. We can start by forcing 10Mb/s to see if we can get a connection and work our way up from there. This may help to eliminate the possibility of a bad cable which is working OK on the other port but not on the docking station.

Please perform the following:

  1. Directly connect the docking station Ethernet port to the NAS device
  2. Right click on the start menu and select “Device Manager” from the menu
  3. Expand the “Network adapters” section
  4. Double click on “Plugable Ethernet” to open the Plugable Ethernet Properties
  5. Select the Advanced tab
  6. Under Property, select “Speed & Duplex”
  7. Under Value, select “10Mbps Full Duplex” from the drop down menu
  8. Click OK at the bottom of the screen
  9. Attempt to Ping the NAS

Please let me know the results of this test.

Thank you,

Plugable Technologies

Yes! You are right! It was the cable! I tried what you mentioned and and it worked at 10Mbps and 100mbps but not 1GB and auto Neg. The NAS is 100Mbps only. I switched the cable and now it works on reg auto neg setting. Thank you so much for your help!! :slight_smile:

Hi Thomaz,

Thanks for letting me know, I am glad that has everything working correctly now!

Please feel free to contact us if you have any additional questions.

Plugable Technologies