Ethernet Connections dropping when routed through dock

I am experiencing an interesting issue with this dock. If I route ethernet traffic through it, either using the built-in ethernet port of attaching an ethernet to USB dongle to an available port on the dock, the link will consistently drop after a few short minutes. The lights on the connection remain, however Windows shows the link failure and access is compromised. I have isolated this to the dock; I can plug the ethernet directly into a computer and ethernet is stable. I have tried multiple computers and ensured I have the driver noted in the downloads for this dock. On that last note, the driver doesn’t come into play when I attempted a workaround using an ethernet to USB dongle attached to the dock. I experience the same problem in that scenario than when I plug into the native 2.5 Gb ethernet port on the dock.


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Very unexpected results that you’re seeing with both the built in Ethernet and also your external Ethernet adapter connected through the dock. I think we’ll need to get a closer look at the software and see if anything stands out.

We have a troubleshooting tool that helps us find out what is going on in situations like this. If you’re able lease plug the dock with the Ethernet cable attached to it into your computer, then go to this page and follow the instructions there:

When emailing us the diagnostics results to as an attachment please mention ticket 399526 in the subject line. Do not post it here!

If unable to run our diagnostics, instead please let me know what brand/model computer is being used with the dock currently.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies

I completed this and the file was sent with subject: ticket 399526 plugdebug zip file

1 Like

More info after additional troubleshooting: I have been able to gain stability when using my MacBook Pro, however several different Windows computers have the same issue; it only stays “connected” for a few minutes before failing. Lights remain on the link, but Internet is lost.

Another note: Windows 11 seems to be upgrading the driver to a 6/22 dated version. When I uploaded the ZIP file, I made sure to remove this and download / install the version on your stie. I am now using driver version 1156.2.20.716 (7/16/21) for Windows 11.

Were you able to get this issue resolved?

I am also having this issue. I’m running a Lenovo T15 Windows 10 machine through this dock. I have been using this dock for a week with no issues, then yesterday I lost all the displays (running 3 Dell 32" @ 2560 x 1440 QHD, 2k). After loosing the displays I tried resetting (unplugging for a minute) the dock, this didn’t fix the issue. I ended up disconnecting the laptop from the dock, rebooting and then reconnecting. Displays came back (for now).
Then today I noticed my laptop was connected via Wi-Fi while docked. I plugged the network cable directly into laptop and it worked, so the issue is definitely with the dock.
I updated drivers using the download link on the TBT4-UDZ product page, even went to the Realtek page to download the latest drivers, as directed on the Plugable product page. Still no ethernet connection. When I reset the dock and then reconnect to laptop, I’ll get ethernet for a minute or so, then it gets dropped.

Again, this dock was working fine for about a week, then it started falling apart.

@jchatz Thanks for sending the diagnostics. I can confirm we’ve received them. Also thank you for the additional information, I appreciate it and the testing you performed.

It’s interesting to hear the MacBook Pro seems to be OK, but that the various Windows systems are all still encountering the issue. I will take a look through these diagnostics and see if anything stands out as to the cause and reply with any suggestions and next steps.

@Steve20 Hello and thank you for reporting this behavior. I’m sorry about these issues and will also be happy to assist you as well.

I would suggest the same for your situation, if able, to perform and send us some diagnostics from the system. We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock with the Ethernet cable attached to it into your computer, then go to this page and follow the instructions there:

Please be sure to email the diagnostics results to Do not post it here!


@Joshua_H I performed and sent in the diagnostics, Bob has been working with me on this. Here’s the latest for anyone else interested:

"Hi Steve,

Thank you for getting back to us with the additional information and confirmation, and I appreciate the detail you have provided.

The PlugDebug log file you provided does not suggest a definitive cause for the unexpected display behavior you described.

The PlugDebug log file does indicate that for some reason Windows is unable to load the driver for the docking station’s internal Ethernet network adapter, however it does not suggest a cause for this condition.

*This unfortunately means that I am unable to explain either behavior definitively. *

As a result, our next step is to provide a replacement TBT4-UDZ docking station that has been pretested in our lab here in the U.S. in order to ensure that everything is working as expected. Doing so will allow us to definitively rule out the docking station hardware as a contributor to the current behavior."

So I will await the tested replacement.


1 Like

Interesting you found “something” w/ Steve’s to why it’s dropping Ethernet but can’t determine why. I have a reason to plug the MacBook back in tonight and will reconnect the Ethernet and update how it goes. Full Disclosure: I never installed the driver from Plugable or Realtek on the MacBook. It just worked.

If I remain stable on the MacBook it still points to something goofy happening between W11 and the ethernet. I think I shared this before, but I also tried an ethernet-to-USB-C adapter, plugged that into the dock, and still had the same issue. A strange one, indeed.

I am experiencing a similar issue as the above, where ethernet fails when connected to the dock but not when connected directly to my laptop. Also similar to the above, I am using Windows 10

@jchatz when I first got the dock, I also just connected the TB4 cable and it just worked… for 5-6 days. It was only when I started having problems did I try to update the drivers. Not sure why Windows won’t load the driver for the dock’s ethernet adapter, but at one point it was working.

I’m also having a very similar issue. I’m on Windows 11, but I haven’t updated any drivers as of yet.

I’ve installed the new drivers on the dock support page. I restarted and the system dock still loses connection with Ethernet after a minute or so. I’ve also tried turning off the Wifi radio to see if that helps make the ethernet connection persist, but it does not help. The ethernet connection still drops.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.