Ethernet & Audio not working in UD 3900


#1

We have been using Plugable UD 3900 on our office successfully for more than a year now on One of the UD 3900 is running with Win10

Audio and ethernet cannot work, the display is working fine I downloaded the latest drivers 8.2 but still does not work

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651323/Image1_inline.jpg?1505727668)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651323/Image1.jpg?1505727668)

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651324/PlugableEthernet1_inline.jpg?1505727688)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651324/PlugableEthernet1.jpg?1505727688)

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651325/Plugableethernet2_inline.jpg?1505727705)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651325/Plugableethernet2.jpg?1505727705)


#2

Wanted to add that the ethernet light is blinking on the dock


#3

Hi Sanjeev,

Thanks for posting! I’m sorry your docking station stopped working as expected and I would be happy to help.

Based on the screenshots you provided, our first step is to perform a ‘clean’ install of the required DisplayLink driver for the dock (which includes the audio and Ethernet drivers) to help ensure everything is in a good state. I know you mentioned you have already installed the latest, but our process adds a few extra steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.2 M3 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system. If the device is not detected, please reboot the system.

Please let us know if that helps when you have a moment, and we will determine the next steps from there.

Thank you in advance for your patience, and giving us the chance to help!

Bob
Plugable Technologies
www.plugable.com/support


#4

Hello Bob,

Thanks for your clear instructions, I did a clean “re-install” step by step
Now I have everything going fine

In fact I have two units one at the office and the other at home both are working perfect now with my laptop

Earlier they were going “on connect” and “off connect” frequently till finally it gave way yesterday to a complete failure

I am sure they will run well now as they were doing for the last year and more
Thanks again and here is snapshot after “re-install”

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651737/PlugableFinal_inline.jpg?1505806064)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1651737/PlugableFinal.jpg?1505806064)


#5

Hi Sanjeev,

Thanks for getting back with the update (appreciate the new screenshot). I am glad things are now working as expected with both docking stations.

Please let us know if you need any help in the future, and please have a good day!

Bob


#6