EasyWorship and Moving Backgrounds Freeze Video


#1

I have Plugable USB-VGA-165 USB to VGA Adapter for Multiple Displays up to 1920x1080 / 1600x1200 Each (DisplayLink DL-165 Chip). I am running Windows 8.1 and EasyWorship 2009. The video seems to freeze after most motion graphics have displayed and I have to quit Easy Worship and reload it to get video to update again. This is troublesome during church service. It works great with non-moving backgrounds. Any ideas on how to fix so I can use this product reliably? We are starting to use more moving backgrounds and it’s becoming an issue.


#2

Hello jykler,

I am sorry to hear this. Depending on the resolution and frame rate of the animations and videos, there might be not a lot we can do since all our display adapters are not designed for video streaming. We can try a clean DisplayLink driver installation to see if this can improve on our symptoms by doing the following:

  1. Disconnect display adapter from the computer
  2. Uninstall DisplayLink Core software from Control Panel -> Programs. Do not worry if this fails, just move onto the next step.
  3. Download and run the DisplayLink cleaner tool -> http://displaylink.com/techsupport_fi…
  4. Once the Cleaner has been run, reboot (do not close the window until you see the message “Cleaning complete. Press ENTER to end.”)
  5. Now download and run the latest DisplayLink software from our downloads page -> http://www.displaylink.com/support/sl…
  6. Reconnect the display adapter to the computer and test.

Please let me know if this yields any results.

Kind regards,
Patric
Plugable Technologies


#3

Thank you for the response! I will try this Wednesday evening and let you know. Basically, we don’t do a lot of streaming on it, mostly just like a countdown or moving backgrounds.


#4

You are welcome! Get back to us whenever you can.


#5