Dual monitors using displayport doesn't work with 2 4k monitors but works with 1 1080p and 1 4k on triple 4k dock

This is for the UD-ULTC4K triple 4k docking station.

What works:

  • 1 4k and 1 1080p using both displayport
  • 1 4k using displayport and 1 4k using HDMI (or vice versa swapping the cables)

What doesn’t work:

  • 2 4k monitors both on displayport (the other monitor on DisplayPort doesn’t detect that there’s an input on its displayport and the screen remains black and on standby)

This is bad because 1) what if I want to do a triple 4k setup, then only 2 monitors will work and 2) the HDMI one is only 30hz and I can see the lag when I move my cursor.

My setup:

  • MacOs 12.3.1 (21E258) (Monterey)
  • Macbook 16", M1 Pro
  • displaylink 1.6.1
  • monitors: acer 4k nitro 28.5"

I’ve noticed in the past you guys have great customer service so thanks in advance !

Hello John,

Thanks for contacting Plugable support! I’m sorry to hear about this display issue through your Plugable dock, but I’d be happy to help!

I’d like to request some logs from your computer to investigate further.

Could you please keep the Plugable dock connected to your system (with the non-working displays still attached), then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there?

Please email the file to support@Plugable.comwith the subject “Ticket #378894

Thanks for giving us a chance to help!

Omar D.
Plugable Technologies

Hi Omar,

Actually today i tried it and it randomly started working (two 4k monitors both on the DisplayPort outputs). I’m thinking restarting my MacBook fixed it. I’ll keep this thread updated if anything goes wrong in the future

Thanks,
John

Hello John,

Thank you for reaching out with that information.

I’m happy to hear that a restart of the system fixed this issue with your dock.

Please feel free to reach out with any additional questions or concerns.

Thanks,

Omar D.
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.