Dual display function abruptly stopped working


#1

Plugable ud-3900 - During normal operations , both of my external monitors stopped working. I have not been able to restore the monitors with the device. All USB ports are working fine.


#2

HI Mike!

Thank you so much for reaching out to us, I am sorry that you are experiencing issues, but I would be happy to assist!

I think the first step we can take is performing a ‘clean’ install of the dock and all of its associated software. This involves uninstalling the drivers, using a DisplayLink cleaning tool, and then reinstalling the drivers again.

If you could, please follow these instructions:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.1 M0 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please click the ‘Skip’ button to allow the process to complete and then reboot the system.

Once you have completed these steps, if the issue is still occurring please keep everything connected and send us the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug as this will allow us to examine some log files from your system to help determine the next steps.

Send the PlugDebug attachment to our support email, support@plugable.com with your ticket #177293 as the subject line.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Marc, Problem fixed! Thanks, Mike


#4

Hi Mike,

That is fantastic! Thank you so much for working through those instructions! Don’t hesitate to email us at support@plugable.com if you have any additional questions or concerns.

Thank you,
Marc


#5